Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
733 Posts
Discussion Starter #1
Great car so far. Only issues: Nav/XM will show XM1 channels and presets while playing XM2 station and vice versa. Some times I do not have the option of selecting XM, through the band button or voice control. Rear right end noise, not associated with the differential. Parking brake does not hold car.

I am scheduled Monday to have these looked at, and I will update you on what actions were taken. And I promise to post those pics of my ride as soon as the DVD system is installed.:)
 

·
Registered
Joined
·
4 Posts
I too have had my 2006 for a month. I haven't had any electrical problems, but I have found the car to accelerate/decelerate as it pleases. Really no rhyme or reason to it. Just has a mind of it's own. I took it to the dealership at 600 miles, but they said Tech Support doesn't want me to bring it back until it has at least 3000 miles. I'm scared I will do some damage to the transmission during this time. At least it's under warranty!
 

·
Registered
Joined
·
316 Posts
Free06CTS said:
I too have had my 2006 for a month. I haven't had any electrical problems, but I have found the car to accelerate/decelerate as it pleases. Really no rhyme or reason to it. Just has a mind of it's own. I took it to the dealership at 600 miles, but they said Tech Support doesn't want me to bring it back until it has at least 3000 miles. I'm scared I will do some damage to the transmission during this time. At least it's under warranty!
My dealer tried that line on me with my CTS when I brought it in with some problems after a couple weeks. Don't accept it..I didn't. I refuse to pay all that money for a new car, and then have the service dept tell me to live with problems for thousands of miles.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
3 Participants
strindl
Top