Cadillac Owners Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
12 Posts
I'm new to this and don't know where to post this.

Hello so I have a 06 Cadillac cts my AC is not working. It blows hot air but not cold, I've checked my freon and I have that. I've checked all the fuses and there good also even the relay is good too. The climate control works but the problem I'm having with the climate control is the ac on and off is not working. It will not let me turn the AC on. Anyone have any ideas?

I'm new to this and don't know where to post this.

Hello so I have a 06 Cadillac cts my AC is not working. It blows hot air but not cold, I've checked my freon and I have that. I've checked all the fuses and there good also even the relay is good too. The climate control works but the problem I'm having with the climate control is the ac on and off is not working. It will not let me turn the AC on. Anyone have any ideas?
 

·
Super Moderator 2005 CTS-V
Joined
·
7,740 Posts
Re: 06 Cadillac CTS - A/C not working

Welcome to the forum. I updated the title of your thread to something useful; a generic title like "06 Cadillac CTS" doesn't give other forum members any indication what the thread is about, thus fewer people will be inclined to open your thread and respond.

It blows hot air but not cold, I've checked my freon and I have that.
What does that mean? How did you check the freon?
 

·
Registered
Joined
·
792 Posts
Re: 06 CTS - A/C not working

Of course, if you are in the north and/ or it's 30 degrees or lower, your AC will also not come on.

Where are you located?
 

·
Registered
Joined
·
6,639 Posts
Re: Largest new style stick on badge

I'm new to this and don't know where to post this.

Hello so I have a 06 Cadillac cts my AC is not working. It blows hot air but not cold, I've checked my freon and I have that. I've checked all the fuses and there good also even the relay is good too. The climate control works but the problem I'm having with the climate control is the ac on and off is not working. It will not let me turn the AC on. Anyone have any ideas?
Welcome, Flobo.
You're in the wrong subforum. You'll get the help you need by starting your own thread in the first generation CTS forum.
Good luck with your issue!

Moderator edit: posts and threads moved from the wrong forums and merged in this CTS first gen forum. The OP has 2 different year CTS cars. Sub.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Like I hooked up a can of freon to it and it was in the green stating that it was full. I am located in Florida so always hot. I just don't understand. It was working great up until a week ago and now when the when I go to hit the AC on/off button it does nothing.
 

·
Registered
Joined
·
9,756 Posts
Re: 06 CTS - A/C not working

When you say that you hit the AC on/off button and it does nothing. Can you elaborate on that? Does nothing change on the HVAC screen? Or does it say AC OFF?

If it says AC OFF, then obviously the AC part is off but the fan is still on. (I know that isn't your problem.) But if you press the AC OFF button again, or hit the AUTO button, to activate the AC. Does that AC OFF not disappear? Or if it does, the air does not cool down?

I see that you checked the fuses. But did you check to see if the relay is actually working? Like swapping it with a known working relay? Also, did you check the AC clutch diode to make sure that's working? If they are all working, can you get an eye on the AC clutch and have someone else cycle the AC OFF button a few times to see if the clutch starts spinning or not? If it does start spinning, leave the AC OFF in the on position, so it should blow colder air, but make sure the clutch stays engaged.

KOT
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
The screen does change in temperature but the Ac button doesn't do anything. It always says AC off. The compressor clutch doesn't kick on. I took out the fuse and forced it on with a paper clip for a second just too be sure it's working and it did so I put fuse back in. I also have a 03 CTS so what I could try is taking that clutch fuse out and trying it on her 06 CTS.
 

·
Super Moderator 2005 CTS-V
Joined
·
7,740 Posts
Re: 06 CTS - A/C not working

Like I hooked up a can of freon to it and it was in the green stating that it was full.
That's what I figured you meant. Those freon cans and their attached gauges are pretty much junk. To know if the refrigerant charge is correct you have to check pressures on both sides of the system while it is operating, and it's not a set number - it's a range depending on ambient temperature and vent outlet temperature. You need to find someone with a set of A/C manifold gauges; I picked up a set at Harbor Freight a couple years ago, have definitely come in handy.

With that said, it doesn't sound like the level of refrigerant charge is the problem. Borrowing the picture below from Ebay - you're saying the "A/C OFF" indication is always on, even when you cycle the "A/C OFF" button? On my car, the default is that the "A/C OFF" indication is off; if yours is always on, and doesn't change, that sounds like somehow the HVAC head unit isn't working right.
 

Attachments

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Yes the AC off is always on. It doesn't change. I also tested it by taking out the HVAC system out of my 03 that has working AC and put it in her car and it still did the same thing in hers. Still showing AC off and not able to change it. Because typically when you hit the AC off button you would hear the AC compressor kick on and then therefore have cold air blowing thru the vents. But even with me switching a known working HVAC into her car it still did the same and didn't change at all.
 

·
Registered
Joined
·
9,756 Posts
Re: 06 CTS - A/C not working

In that case, have the charge checked properly as previously mentioned. The HVAC unit isn’t the problem, as you found out. Something else is telling them system not to kick on, could be lack of too much charge. Or could be a faulty sensor.

KOT
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
I'll take it to get the system checked Friday. Also what is the sensor called that could also be the problem
 

·
-Administrator- 2002.5 F55 STS 2014 FWD Explorer
Joined
·
66,593 Posts
Probably a refrigerant high or low pressure sensor.

I have moved and merged a few of your previous posts from some wrong forums. I see that you have both a 2006 and a 2003 CTS. Please read the title banner notes to learn what is supposed to be posted in the forum you are looking at.

Your user profile has been updated to show that you have two CTS vehicles. In the first post of a new thread always identify which vehicle you are seeking advice on.
 

·
Registered
Joined
·
1 Posts
I'm new to this and don't know where to post this.

Hello so I have a 06 Cadillac cts my AC is not working. It blows hot air but not cold, I've checked my freon and I have that. I've checked all the fuses and there good also even the relay is good too. The climate control works but the problem I'm having with the climate control is the ac on and off is not working. It will not let me turn the AC on. Anyone have any ideas?

I'm new to this and don't know where to post this.

Hello so I have a 06 Cadillac cts my AC is not working. It blows hot air but not cold, I've checked my freon and I have that. I've checked all the fuses and there good also even the relay is good too. The climate control works but the problem I'm having with the climate control is the ac on and off is not working. It will not let me turn the AC on. Anyone have any ideas?
My car did the same did you ever get this figured out??
 
1 - 14 of 14 Posts
Top