Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2005 sts
Joined
·
2 Posts
Discussion Starter #1
Hello, I Have A 2005 Cadillac Sts. A Few Days Ago The Radio/Navigation Didnt Turn On when I Started The Car up. I Purchased A New Fuse And Replaced The Old One, I Then Started the Car Up And It Came on. But When I Turned The Car Off For About 20 Minutes It Didnt Come on Again. Please Help If You Know What Could Be The Cause! It Was Working Fine With No Problems For About 2 Months.
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,479 Posts
Try resetting the entire system by disconnecting the positive battery cable for about 15 minutes or so...can't hurt to try.
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
Unfortunately, that fuse is blowing for a reason. If the reset doen't help, a good dealer is your friend.
 

·
Registered
2006 STS4 V8 1SG & 2007 STS V8 1SE
Joined
·
8,178 Posts
C - I said 'Good' not 'Hungry'. They do exist (even if you haven't met one lately.)
 

·
Registered
2006 STS V8 1SF RWD
Joined
·
6,479 Posts
EChas3 said:
C - I said 'Good' not 'Hungry'. They do exist (even if you haven't met one lately.)
Lol! My local GM dealer has been 'good' to me over the years... It's just that my Cadillac's have only ever gone there when something broke that I couldn't replace myself, and that usually comes with a decent sized bill.
 

·
Registered
STS 1SF Black V8 2006
Joined
·
456 Posts
It's going to require a Factory Service Manual, the talent and experience to read it to find a bare wire, a bad ground, a stuck relay... did it get wet?
 
1 - 8 of 8 Posts
Top