Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
2005 CTS
Joined
·
16 Posts
Discussion Starter #1 (Edited)
2005 CTS "D" shift light issue - rough shift - loses gear position while driving

I have a 2005 CTS 3.6 automatic. On cold start everything works fine. After about 10 minutes the "D" light on the shift panel goes out. Rough shifts. When braking you can hear to park solenoid releasing. Pushing the shifter about 1/4" forward makes the "D" light come on again... the solenoid does not release when the light is on. When this happens and moving the shifter to the "numbers", "3" and ""2 does not work and jumps to "1".

What is it?
1. shift linkage out of bias and/or bushings bad
2. could be the shift indicator (Range Switch) located inside the transmission is bad

also possible that ecu, tcm, wiring?!?

Anyone have a similar problem?
 

·
Registered
2005 CTS
Joined
·
16 Posts
Discussion Starter #3
Re: 2005 CTS "D" shift light issue - rough shift - loses gear position while driving

Hey thanks for the reply... that's what it sounds like to me also. I did the clutch pressure release solenoid about a year ago. When i took it out it looked like the plastic just disintegrated. I might have to do the range switch too... I will try the shift linkage adjustment first cause the switch is about $70 and looks like a lot of work.

Its just funny how it all works fine in the morning on cold starts. Luckily it's not my daily driver and I can take my time on it.
 
1 - 3 of 3 Posts
Top