Cadillac Owners Forum banner

1 - 16 of 16 Posts

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #1
Hi,

So I'm having an issue where when driving at low rpms that it seems that the car makes a slight hallow grinding noise but then goes away when I let go of gas and press the accelerator harder. I'll also occasionally get a slight jerk between 1st to 2nd gear and once in a while 2nd to 3rd gear. So not sure what this can be but also was seeing if maybe a transmission fluid change is in need. The truck car has 133k on it and I got it at 81k and never had the transmission fluid changed.

Also when on the highway I'm hearing this (shopping cart wheel-like sound) and have no idea what it can be. I don't see anything loose at all and don't believe it's the brakes at all as well. I posted a video on youtube so that you can try to hear it as well. (https://www.youtube.com/watch?v=_0VPv0zmSaM)

Please someone let me know as I do want to take care of this car as best as I can. I don't drive much since I live in NYC so I know with good care I can make this car last a while.

Thanks
 

·
Registered
2008 SRX Sport Pkg
Joined
·
1,135 Posts
One thing that it could be is a worn idler or tensioner pulley. Both pullies guide the V-belt or accessory belt. You can check them as follows:
-park in a safe place and open the hood and have someone start the engine and press the accelerator.
-watch to see if the tensioner pully is swinging back and forth (this is normal, but not if it is long, wild swings and extremely jerky). It normally swings within an inch or so, so some jumping is okay

-have the driver increase engine speed and see if the sound appears to come from the front of the engine block. Obviously, do not reach in or wear stuff that can get caught in a fan or belt!!! Stay well clear of ALL moving parts.

If it is one of the pulleys, they are pretty easy and cheap to replace.
 

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #3
So are you saying that what you mentioned could be the issue for both issues I said above? Both the Sound and the jerking? Also to mention the jerking doesn't happen all the time. Sometimes the car runs smooth when shifting gears and other times it jerks.

Let me know.

----------

One thing that it could be is a worn idler or tensioner pulley. Both pullies guide the V-belt or accessory belt. You can check them as follows:
-park in a safe place and open the hood and have someone start the engine and press the accelerator.
-watch to see if the tensioner pully is swinging back and forth (this is normal, but not if it is long, wild swings and extremely jerky). It normally swings within an inch or so, so some jumping is okay

-have the driver increase engine speed and see if the sound appears to come from the front of the engine block. Obviously, do not reach in or wear stuff that can get caught in a fan or belt!!! Stay well clear of ALL moving parts.

If it is one of the pulleys, they are pretty easy and cheap to replace.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
I think 08 was referring to the noise, not the jerking. As to that, a fluid change is probably a good idea. Make sure they check the fill level when done. Might also check the transfer case for fluid and chain slack.
 

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #5
I think 08 was referring to the noise, not the jerking. As to that, a fluid change is probably a good idea. Make sure they check the fill level when done. Might also check the transfer case for fluid and chain slack.
So just wanted to make sure that this is ok to do with 133K miles. I hear mixed comments from people about getting the fluid changed or not.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
Well, there are all kinds of stories- guess it depends on which one you want to believe.
 

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #7
So i got the transmission fluid changed. The jerking is still there. It seems to happen only though when RPMS are lower but if I floor it or give it a good amount of gas then it doesn't jerk through gear shifting.

Any thoughts here? Also to note yesterday was the first time I seen that the check engine light was flashing but then went away.

Thanks and let me know.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
Give it some time. It may take awhile for the new fluid to clean things up.
 

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #9
How long should it be though? I have driver it already for 200+ miles as I driven it back and forth from NY to CT.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
200 mi. isn't much. It takes time to dissolve varnish that may be causing the jerking. In any case, I doubt you've done any harm by changing the fluid.
 

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #11
is there any other process besides driving that I can do to help get the fluid flowing through better?
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
There's 8 or 10 valves in the transmission that work when shifting gears. So a drive cycle that goes up and down through the gears will give them (valves) the most action. They are solenoid driven and have O-rings for sealing so the more they move the quicker the varnish will wear away.
 

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #13
Just out of curiosity could it be possible that the fluid level wasn't placed in correctly or filled to the correct level I mean?
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
It's possible, if they didn't know you have to fill with engine running.
 

·
Registered
2005 Cadillac SRX V6 AWD
Joined
·
30 Posts
Discussion Starter #15
I'm definitely going to inform them of that. I was actually watching them as I was curious and it did not look like they filled it with the engine running. They turned it on after they removed the hose or whatever they were using.
 

·
Registered
05 srx awd v6 (gone), '07 GXP, 2010 li'l red wagon 3.6
Joined
·
3,177 Posts
OK, did you have a flush or drop the pan and refill? Hope it's not the latter.
 
1 - 16 of 16 Posts
Top