Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
2008 STS
Joined
·
9 Posts
Discussion Starter · #1 ·
Having a serious problem. When trying to start my car it won't start intermintently. Here are the symptoms: I try to start my car just as I do any other day and it trys to turn over but it doesn't. It just makes the noise like it wants to start but then the "check engine" light comes on the dash for about 20 seconds and then all of the other display intruments come on. The only remedy I have found is to disconnect the battery for almost 10 hours and then I reconnect it and it fine. This will last for approximately 2 weeks until it happens again but i've just been lucky the problem has happened when im not at home.

Ive seen others in the past such as HILJAK have this problem and others have commenting on the problem but they get no answers. Also when I called Caddy customer service they explained that a service bulletin #05524 had already been done on my car which reprograms the ECM. Is it possible that I need to get this reprogram again?

Please Help!!
 

·
Registered
'05 STS4
Joined
·
668 Posts
Get it scanned for codes. Why guess what's wrong when there's probably a code in memory to tell you ;)
 

·
Registered
2008 STS
Joined
·
9 Posts
Discussion Starter · #4 ·
Ok here is an update. I have the v6 model with about 102k miles on it. I also tested for codes and there are no codes showing up. It is surely not the battery nor the connections on the battery and usually when I disconnect the battery and allow it to sit for 10 hours or so it starts right up. This is not the case at this time. It will not start up at all. Any ideas??
 

·
Registered
2006 STS 1SG & 2007 STS 1SE
Joined
·
14 Posts
You say it is surely not the battery? That's your most likely suspect. Why so sure?

Have you cleaned both ends of both battery cables and tried a known good battery?
 
1 - 5 of 5 Posts
Top