Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
2003 CTS<-- Gone! New-->2004 SRX
Joined
·
13 Posts
Discussion Starter #1
So if I control the AC from the front the rear only blows on high, if I put it on rear control- and turn it- it only works on high. Any ideas? Thank you!
 

·
Registered
04 SRX
Joined
·
13 Posts
The speed resistor for the rear fan, most of the resistor are a microchipped board and the plug going into them tend to overheat and melt the plug so it will not disconnect. And the reason the fan works on high speed, is that high speed is wired directly to the fan whereas the lower speeds have to run through the different resistors in the board or spring coils. I haven’t had mine out yet, but experience of selling parts sounds directs me to this conclusion. If a new resistor doesn’t last long, your blower motor could be drawing high amperage causing it to overheat and burn out quickly.


Sent from my iPhone using Tapatalk
 

·
Registered
2003 CTS<-- Gone! New-->2004 SRX
Joined
·
13 Posts
Discussion Starter #5
My apologies for not thanking you all sooner. Just made it back to the forum. I am ordering the part tonight. On another note, if your cadi keeps going to limp mode, try cleaning your tps connector first. :)
 

·
Registered
EU - SRX 2004 N* (with autogaz system) AWD, 7seat, trailer hitch westfalia.
Joined
·
300 Posts
Behind rear left pannel.
 

·
Registered
2003 CTS<-- Gone! New-->2004 SRX
Joined
·
13 Posts
Discussion Starter #8
Thank you, I will be working it on monday, dang 7 day work weeks.
 
1 - 9 of 9 Posts
Top