Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
While I was driving home yesterday I lost all power to my Escalade and had to coast onto a grassy median in traffic. We just changed the fuel pump and we have a new battery. Any idea what it could be or what to look for? Thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
No. It just died and that was it. For awhile now the reduced engine speed would come in and only was able to go 35 mph but after it sitting for a few hours it would be fine. My husband scanned for codes today, not sure what code said but he tried to start it and it started! No clue what is going on...
 

·
Registered
08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
Joined
·
1,852 Posts
Need to know what code, of the reduced power message came on there should be an engine light and a stored code
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
Reduced engine power is only triggered by the throttle body sensors or the pedal sensors (unless the pcm goes nutty then all hell breaks loose)

Likely one of the two is going flaky

Like the others have said get the codes and post them it helps a lot

----------

djais1801 said:
sounds like a vapor lock...or maybe the alternator...did the battery light come on?
Vapor lock does not cause the reduced engine power message(been there before)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
It was the crankshaft throttle body sensor. My Husband replaced it yesterday. Fingers crossed! Also fixed the "reduced engine power" sensor

----------

It wasn't throwing any codes but then they tried it right after it died once again and it was the throttle body sensor.
 

·
Registered
'05 ESV Platinum, 250,000 still looking fine, really fine!
Joined
·
1,133 Posts
Glad your husband got it fixed! Thank you for the follow up.
 
1 - 9 of 9 Posts
Top