Cadillac Owners Forum banner

1 - 17 of 17 Posts

·
2003 Deville
Joined
·
19 Posts
Discussion Starter #1
HI,, Trying to figure out my 03 deville problem.. when i am driving along,,the throttle kind of stays where its at when i take my foot off the pedal,,it just goes right along as if i have my foot on the pedal.. it will slowly start coming down rpm and m.p.h. ,,a little at a time...now,when i hit the brakes the car stops with like around 1000rpm, but drops down to the 750rpm... now i have the cruise button off on the steering wheel.. now this happens at any speed,,60-70- 30-.. its kind of like sticking throttle... i can't figure it out.. all help will be appreciated for this old senior..thanks
 

·
Super Moderator 2003 Deville Base ΜΟΛΩΝ ΛΑΒΕ
Joined
·
4,243 Posts
I changed your thread title to be more descriptive. First and always, pull codes and post them here WITH their definitions. Will also be helpful if you tell us whether your 03 is a base, DHS or DTS. Someone will chime in with info
 

·
Super Moderator
Joined
·
86,087 Posts
When was your TB last cleaned? Sounds a bit like the throttle plate is hanging up on carbon build up in the throttle body bore.
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,724 Posts
I agree -
#1 - check for codes -
#2 - inspect/clean the TB - Throttle Body AND the IAC - Idle Air Control solenoid -
 

·
2003 Deville
Joined
·
19 Posts
Discussion Starter #6
ok,, today i took and cleaned the throttle body and the iac..the iac only had heavy black dirt,not caked on carbon,it all cleaned fairly easy..now, the throttle body had some caked on carbon,that i scraped off and cleaned with throttle cleaner and rags,, the throttle plate was not sticking..i took off the cable connecting to throttle for cruise control..so i know its not that..i started up engine ,my hand in on the throttle control right on the throttle housing,,reved up the engine,and i pushed the throttle control back down to its low resting spot,,the engine stays reved up a few seconds,,then its like something clicks off,and engine comes down to idle.. i tried this several times at different rpms,and push the throttle with my hand back down on its low spot,which should be idle,, it still stays reved up a few seconds,,then something clicks like off,,then engine comes down to idle.. yes sir.. 2003 deville base northstar..i can't read codes yet,,soon as my son gets here... any ideas to my so far testing i explained ?
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,724 Posts
ok,, today i took and cleaned the throttle body and the iac..the iac only had heavy black dirt,not caked on carbon,it all cleaned fairly easy..now, the throttle body had some caked on carbon,that i scraped off and cleaned with throttle cleaner and rags,, the throttle plate was not sticking..i took off the cable connecting to throttle for cruise control..so i know its not that..i started up engine ,my hand in on the throttle control right on the throttle housing,,reved up the engine,and i pushed the throttle control back down to its low resting spot,,the engine stays reved up a few seconds,,then its like something clicks off,and engine comes down to idle.. i tried this several times at different rpms,and push the throttle with my hand back down on its low spot,which should be idle,, it still stays reved up a few seconds,,then something clicks like off,,then engine comes down to idle.. yes sir.. 2003 deville base northstar..i can't read codes yet,,soon as my son gets here... any ideas to my so far testing i explained ?
======================
any ideas to my so far testing i explained ?
YES -
snapping the throttle on the Northstar is NOT like snapping the throttle on a carbed engine -
returning down to idle speed is NOT instantaneous - but it should quickly settle at a steady 650rpm -
 

·
Super Moderator 2003 Deville Base ΜΟΛΩΝ ΛΑΒΕ
Joined
·
4,243 Posts
ok,, today i took and cleaned the throttle body and the iac..the iac only had heavy black dirt,not caked on carbon,it all cleaned fairly easy..now, the throttle body had some caked on carbon,that i scraped off and cleaned with throttle cleaner and rags,, the throttle plate was not sticking..i took off the cable connecting to throttle for cruise control..so i know its not that..i started up engine ,my hand in on the throttle control right on the throttle housing,,reved up the engine,and i pushed the throttle control back down to its low resting spot,,the engine stays reved up a few seconds,,then its like something clicks off,and engine comes down to idle.. i tried this several times at different rpms,and push the throttle with my hand back down on its low spot,which should be idle,, it still stays reved up a few seconds,,then something clicks like off,,then engine comes down to idle.. yes sir.. 2003 deville base northstar..i can't read codes yet,,soon as my son gets here... any ideas to my so far testing i explained ?
why can you not read codes? do you have the DIC set to read rpm? It's very accurate. Once mine is at operating temp it reads 650rpm, 675 if the a/c is on, which here in Texas is pretty much always.
 

·
2003 Deville
Joined
·
19 Posts
Discussion Starter #9
finally i figured out the codes,, wow theres a few..2003 deville base northstar...abs1223=lr wheel speed sensor input signal is 0..,1227 lr excessive wheel speed variation..,1287 steering sensor rate mulfunction...,1226 rf excessive wheel speed variation ..1233 rf wheel speed circuit openor shorted..rfa co755,co765,co760,,i think these are low tire sensor..not worrying about these,these are history.. no amp,ddm,dds,dim,ipc,lrd,msm,pdm,rcc,rim,rrd,sdm,vtd..u1305 class 2 data link low or high...bo429 temperature control #3rear circuit range/performance...b1004 keep alive memory....po443 evaporative valve 1 control ckt...OK, i did the best i could..also engine lite on,and service stability system comes across dash... please help.. thanks
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,724 Posts
finally i figured out the codes,, wow theres a few..2003 deville base northstar...abs1223=lr wheel speed sensor input signal is 0..,1227 lr excessive wheel speed variation..,1287 steering sensor rate mulfunction...,1226 rf excessive wheel speed variation ..1233 rf wheel speed circuit openor shorted..rfa co755,co765,co760,,i think these are low tire sensor..not worrying about these,these are history.. no amp,ddm,dds,dim,ipc,lrd,msm,pdm,rcc,rim,rrd,sdm,vtd..u1305 class 2 data link low or high...bo429 temperature control #3rear circuit range/performance...b1004 keep alive memory....po443 evaporative valve 1 control ckt...OK, i did the best i could..also engine lite on,and service stability system comes across dash... please help.. thanks
========================
this is VERY hard to read/follow -

help US to help YOU -

when ever referring to codes -
ALWAYS include the ENTIRE code - a letter - B - C - P - U - followed by four numbers -
also include whether the code is C = Current or H = History -
and - of course - the DEFINITION -

example:
B0429 - C - Temperature Control #3 Rear Circuit Range/Performance
C0760 - C - Tire Pressure Monitor (TPM) system sensor not transmitting
P0443 - C - EVAP Purge Solenoid Valve 1 Control Circuit
 

·
2003 Deville
Joined
·
19 Posts
Discussion Starter #11
ABS codes=C1223,C1227,C1287,C1226,ARE History,not really worried about them...Due to i think the electronic control module is bad.......NO amp,ddm,dds,dim,ipc,lrd,msm,pdm,rcc,rim,rrd,sdm,vtd........PO443 This is the evaporative purge valve,not to worried about that at this moment.......B1004 Keep alive memory........BO429 Temperature control #3 rear circuit range/performance........U1305 Class2 data link low or high........CO755 INternal SDM Failure........CO765 Passenger air bag deployment commanded....the C =chassis..O=sae...7=transmission...
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,724 Posts
ABS codes=C1223,C1227,C1287,C1226,ARE History,not really worried about them...Due to i think the electronic control module is bad.......NO amp,ddm,dds,dim,ipc,lrd,msm,pdm,rcc,rim,rrd,sdm,vtd........PO443 This is the evaporative purge valve,not to worried about that at this moment.......B1004 Keep alive memory........BO429 Temperature control #3 rear circuit range/performance........U1305 Class2 data link low or high........CO755 INternal SDM Failure........CO765 Passenger air bag deployment commanded....the C =chassis..O=sae...7=transmission...
=========================
ABS codes=C1223,C1227,C1287,C1226,ARE History,not really worried about them..
.Due to i think the electronic control module is bad..

WRONG -
NONE of these codes have ANYTHING to do with the ABS module -

if you had looked up - and posted the code DEFINITIONS -
you could have figured that out all by yourself -

and some of the code definitions you DID post are WRONG -
CO755 INternal SDM Failure. -
NOPE -
C0755 - Tire Pressure Monitor (TPM) system sensor not transmitting

CO765 Passenger air bag deployment commanded..
NOPE -
C0765 - Tire Pressure Monitor (TPM) system sensor not transmitting

here ya go -
I'll look up the codes and post the CORRECT DEFINITIONS so you won't be bothered -

C1223 - Left Rear Wheel Speed Sensor Input Signal is 0
meaning IF the sensor IS plugged in - you need a new L/R bearing/hub -

C1226 - Right Front Excessive Wheel Speed Variation -
you need a new R/F hub/bearing - the sensor is failing -

C1227 - Left Rear Excessive Wheel Speed Variation -
verifies the L/R hub/bearing needs to be replaced - the sensor is failing -

C1287 - Steering Sensor Rate Malfunction -
you need to replace the Steering Wheel Position Sensor -
a momentary glitch of this sensor is all it takes to set this code -
THIS DTC causes the CHECK STABILITY SYSTEM message on the DIC -

...the C =chassis..O=sae...7=transmission...
WRONG AGAIN -
C = CHASSIS which has absolutely NOTHING to do with the TRANSMISSION -

P = POWERTRAIN = engine and transmission -

-----------------------

now - was that SO difficult?

you're welcome
 

·
-Administrator- 2002.5 F55 STS 2014 FWD Explorer
Joined
·
66,322 Posts
MYHELIGUY, diagnostic trouble codes read out as a letter, 4 digits, a letter.

P = Powertrain
B = Body
C = Chassis
U = power and data

C = Current (the fault exists now)
H = History (the fault has not been detected for X startup/run events)

Example: P 0300 C - engine misfire detected - (a handheld or parts store scan will show the cylinder number, like P 0304 C)

Please bookmark the below link and use it when posting about codes and problems. Thanks.

 

·
2003 Deville
Joined
·
19 Posts
Discussion Starter #14
The problem i am having is=i can take my hand on the throttle where the cables connect too, i can rev up engine to say around 2000 rpm,,let the throttle back down to idle even holding my hand on it to idle,but the engine stays rev up for a few seconds,then something like clicks{a solenoid possibly i can hear it}then the engine starts to idle...also i can be going down the road at say around 50mph{or really any speed} let off the gas pedal,,the speed stays the same for awhile{possibly a few city blocks} then all of a sudden the car starts to slow down...even when i hit brake it will idle up when coming to stop.....what can be this click then engine idles?
 

·
Super Moderator 2003 Deville Base ΜΟΛΩΝ ΛΑΒΕ
Joined
·
4,243 Posts
The problem i am having is=i can take my hand on the throttle where the cables connect too, i can rev up engine to say around 2000 rpm,,let the throttle back down to idle even holding my hand on it to idle,but the engine stays rev up for a few seconds,then something like clicks{a solenoid possibly i can hear it}then the engine starts to idle...also i can be going down the road at say around 50mph{or really any speed} let off the gas pedal,,the speed stays the same for awhile{possibly a few city blocks} then all of a sudden the car starts to slow down...even when i hit brake it will idle up when coming to stop.....what can be this click then engine idles?
are you even reading the suggestions and questions? Re-read posts 10 & 13 about posting codes and definitions. Lots of experienced folks trying to help you to come to a diagnosis.
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,724 Posts
The problem i am having is=i can take my hand on the throttle where the cables connect too, i can rev up engine to say around 2000 rpm,,let the throttle back down to idle even holding my hand on it to idle,but the engine stays rev up for a few seconds,then something like clicks{a solenoid possibly i can hear it}then the engine starts to idle...also i can be going down the road at say around 50mph{or really any speed} let off the gas pedal,,the speed stays the same for awhile{possibly a few city blocks} then all of a sudden the car starts to slow down...even when i hit brake it will idle up when coming to stop.....what can be this click then engine idles?
===========================
unplug the ISC solenoid -
 

·
2003 Deville
Joined
·
19 Posts
Discussion Starter #17
replaced the tps,,that helped in idle misfire and trans shifting...i ordered the iac on ebay,, hopefully its good,, cause the idle is just at whatever your gas pedal is at when you driving at any speed... i found they call this coasting/sailing.... if i am doing 15mph,,take my foot off pedal,it stays at 15mph..or any speed it does that... trying hard to fix.. i do appreciate all everyones help..p.s. i did unplug the iac,it just started increasing rpm,,i turned off engine at about 2000rpm..
 
1 - 17 of 17 Posts
About this Discussion
16 Replies
5 Participants
MYHELIGUY
Top