Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 2 of 2 Posts

·
2003 DHS
2003 Cadillac Deville DHS
Joined
·
5 Posts
Discussion Starter · #1 ·
I can get the radio to turn on for a second when I first start my car but then it goes blank and only shows the clock. I wanted to see if this is an easy fix or a more difficult fix? Maybe just a blown fuse? My car is a 2003 Cadillac Deville DHS and I will attach a picture of my radio but note that this is a picture of it before the radio stopped working. Ps. Every now and then my radio will work randomly after a few days of being home when I go to leave and try my radio, soemtimes it works.?? But it’s honestly a pain and is mostly not working more than the random lucky few times it randomly worked when first turning on the car. It’s been really rough trying to troubleshoot when or most importantly WHY and WHAT is causing my radio to not work. I would greatly appreciate any help I can get as it seems it’s been over a month and still can’t figure out the underlying issue here.
thanks in advance for any help. I am a 28 year old college student who loves her radio! I know it’s not a necessity nor a major need, but it is something I enjoy on my way to my destination! ☺
596086
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
20,803 Posts
I can get the radio to turn on for a second when I first start my car but then it goes blank and only shows the clock. I wanted to see if this is an easy fix or a more difficult fix? Maybe just a blown fuse? My car is a 2003 Cadillac Deville DHS and I will attach a picture of my radio but note that this is a picture of it before the radio stopped working. Ps. Every now and then my radio will work randomly after a few days of being home when I go to leave and try my radio, soemtimes it works.?? But it’s honestly a pain and is mostly not working more than the random lucky few times it randomly worked when first turning on the car. It’s been really rough trying to troubleshoot when or most importantly WHY and WHAT is causing my radio to not work. I would greatly appreciate any help I can get as it seems it’s been over a month and still can’t figure out the underlying issue here.
thanks in advance for any help. I am a 28 year old college student who loves her radio! I know it’s not a necessity nor a major need, but it is something I enjoy on my way to my destination! ☺ View attachment 596086
=======================
STEP #1 - ALWAYS - check for DTC's - Diagnostic Trouble Codes - using the on-board scanner -
if you don't know how - go here -

post any codes you have -
ALONG WITH THEIR DEFINITIONS -

include whether they are C-Current or H-History -

for code definitions - go here -

here is a how-to video -

---------------------------------------
intermittent problems are the most difficult to diagnose and fix -

it's NOT a fuse -
when a fuse blows - the entire circuit is absolutely dead -
until the blown fuse is replaced -

the problem COULD be a loose connection in the back of the radio -

or it could be within the radio itself -

removing the radio is actually quite easy -
with NO special tools or skills required -

let me know if you want to try this -

---------------
 
1 - 2 of 2 Posts
Top