Cadillac Owners Forum banner

1 - 20 of 28 Posts

·
Registered
2003 Deville base
Joined
·
258 Posts
Discussion Starter #1
Looking to buy a new iac for my 2003 cadillac deville. I've seen them on ebay for anywhere from 9 bucks to 100 bucks all brand new.anyone have any input on a good one?
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
AC Delco only.

Check rock auto and Amazon for (some of) the best prices.
 

·
Registered
2003 Deville base
Joined
·
258 Posts
Discussion Starter #4
currently I am just suspecting that is the cause of my problem my rpms have been jumping up and down irregularly and I already did a good cleaning of the throttle body and the idle air control even after the cleaning it seems a little better but when the car is in park they still jump up to 1000 or 2000 rpm.then when I put the car in drive they drop back down to 600 no check engine lights or codes are present.
 

·
Registered
2003 Deville base
Joined
·
258 Posts
Discussion Starter #5
I notice the AC delco or top brands are all around 200+ dollars? I know you get what you pay for just not looking to spend that much. any idea if any of the middle road ones $50-$100 are worth trying? I'm thinking the $9 one isn't any good.
 

·
Registered
05 Deville
Joined
·
401 Posts
Go with a good used one over a cheap brand new one.
Have got one in my tool bag, $30 @ picnpull
 

·
Registered
Devilles: 04 Base,01 base,01 DHS,92 (parents)
Joined
·
211 Posts
When I had this issue. I got my replacement acdelco one for $10 at a salvage yard. Cleaned it up. Works great.
 

·
Registered
2003 Deville base
Joined
·
258 Posts
Discussion Starter #9
You say you got a replacement for yours and cleaned it up and it worked why couldn't you just clean your old one up is there something else that goes wrong with them other than getting dirty
 

·
Registered
Devilles: 04 Base,01 base,01 DHS,92 (parents)
Joined
·
211 Posts
I don't know the technical reasons.... But I did try cleaning my original iac valve, but it didn't help. I feel the original one is broke/dead.

The cars at junkyard are usually there because of a wreck so some parts are perfectly fine. But as always your mileage may vary.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,985 Posts
I don't know the technical reasons.... But I did try cleaning my original iac valve, but it didn't help. I feel the original one is broke/dead.

The cars at junkyard are usually there because of a wreck so some parts are perfectly fine. But as always your mileage may vary.
===========================
I don't know the technical reasons...
it was broken -
 

·
Super Moderator
2003 Deville Base
Joined
·
5,261 Posts
it was broken -
:yup: not THAT cracked me up. Occam's razor (also written as Ockham's razor) The principle states that among competing hypotheses that predict equally well, the one with the fewest assumptions should be selected.
 

·
Registered
2007 DTS
Joined
·
63 Posts
I bought an IAC valve on ebay for 15 dollars a year ago for my 04 deville ,, havent had no problems other than when i first put it in on D rpms were at 750, n now they at 650 when i stop at a stop light,, i guess it had to settle in,,, cant even feel the engine running n i got 194,000 miles n she still running like a champ
 

·
Registered
2002 STS, 2005 CTS 3.6
Joined
·
413 Posts
currently I am just suspecting that is the cause of my problem my rpms have been jumping up and down irregularly and I already did a good cleaning of the throttle body and the idle air control even after the cleaning it seems a little better but when the car is in park they still jump up to 1000 or 2000 rpm.then when I put the car in drive they drop back down to 600 no check engine lights or codes are present.
Did you take it completely apart to clean it? Dissasemble it completely, twist out the plunger and pull out the spring, then clean it good. When reassembling, twist the plunger all the way back in. You'll likely save yourself a bunch of cash. Easy job, they get gummed up bad over time.
 

·
Registered
97 ETC x2, 04 GXP, 04 STS x2, 97 ESC, 99 Deville, 05 SRX
Joined
·
2,603 Posts
I just replaced the one on 04GrandAmGT's DTS. I just put a used one in. Works good, for now. Used parts can fail but if you have them or it's cheap, why not? :)
 

·
Registered
2003 Deville base
Joined
·
258 Posts
Discussion Starter #16
before anyone asks I'm not getting any codes :) I did clean the idle air control really good and throttle body about a month ago the RPMs seem to be ok now other than the occasional glitch however whenever the car is in park it's still constantly shaking very weird almost like someone is tapping on the gas pedal a little bit but the RPM stay at 650 why would that be? would that be my plenum I'm waiting on to replace or something else
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,985 Posts
before anyone asks I'm not getting any codes :) I did clean the idle air control really good and throttle body about a month ago the RPMs seem to be ok now other than the occasional glitch however whenever the car is in park it's still constantly shaking very weird almost like someone is tapping on the gas pedal a little bit but the RPM stay at 650 why would that be? would that be my plenum I'm waiting on to replace or something else
==================
this car sure seems to have a LOT of issues -
if it was a human - it would be a hypochondriac -

hmmm - Münchausen syndrome by proxy might explain things too -
 

·
Registered
2007 DTS
Joined
·
63 Posts
Mite wana check a vacuum hose first,, check your pcv dirty air hose and pcv clean air ,, pcv dirty air comes from top back valve cover to under intake thru passenger side,, that elbow under intake ussually dry rotts,,,
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
70,336 Posts
Here's the dirty air end of the intake manifold - the PCV line runs from the rubber connector at the right (rear) cam cover to the center tunnel of the manifold. Your engine does not have the old style "rattle valve" PCV - it uses a fixed orifice in the cam cover fitting.

If the pipe is broken or the rubber end connectors are rotted the entire mess can be replaced by a proper sized length of reinforced fuel hose from any parts store. The connector inside the manifold center tunnel is no fun to get to.
 

Attachments

1 - 20 of 28 Posts
Top