Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 13 of 13 Posts

·
Registered
CTS
Joined
·
3 Posts
Discussion Starter · #1 ·
I am in the process of purchasing a 2003 CTS with 59,000 miles on it and during my test drive I smelled something funny....come to find out today that it was the head gasket or something. The dealer replaced it and stated they will warranty it obviously, however it is a tad concerning.

I guess I just am curious on if anyone else had this issue and if its common, or should I be a tad more concerned that this is something serious? Also any other common issues that I should be aware of with the 2003 model year?! I am in love with this car after driving and really want to move forward, just a bit taken back by this repair just prior to purchasing! Thanks!
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
thats very low mileage, take a better look at the dash cluster, does it have a analog clock on it or a engine temp gauge? the 2003 came with a clock, if its got engine temp its not the origonal cluster, meaning that someone may have put a newer one in with low mileage.
the 3.2 is a good running engine, so long as you take care of it. the timing belt needs to be serviced at 100mi, and you need to keep a eye out for valve covers leaking due to a bad pcv design that is affected by the cold.
make sure the differential is nice and quiet, they are known to howl and then will eventually need to be replaced.
transmission cooler line is a common flaw on the 03-2007 cts...breaks off from the rad so make sure its not leaking, if it is change right away, if not then plan to change asap before you have a problem.

other than that, just look for other leaks, and odd noises, you can expect the idle to shake a little but not excessive.

good luck, ive had my 03 for almost 3 years now and i love her.
 

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
Valve cover gaskets leaking, transmission lines disconnecting because the radiator is rusted and brittle. Those are 2 of the main ones for the 03
 

·
Registered
CTS
Joined
·
3 Posts
Discussion Starter · #4 ·
I dont remember if it had a clock - like in the center or in the actual dash? I have the weblinks to the photos of the dash but I cant post because im new :(

And I will keep my eye on those things as well before I make my final but I am in love with this car!!!!!! I did make a mistake, it has 64000 miles on there, I did drive a different make/model car and that one had less miles...but still the condition of this car is absolutely amazing!! I was just floored on how good of condition it was in! Hopefully when I have the final "look over" with my mechanic, aka Dad, he will approve. He has been in the industry for a while but I havent had him look over yet, so that will be the ultimate test! I will give him the list for sure to keep a close eye on! Thanks guys!
 

·
Registered
04 Blacked Out CTS 3.6L
Joined
·
19 Posts
another problem you can encounter besides the the differential which is a really common problem is the ecm failing around 100k but other than it is an amazing car.
 

·
Registered
2003 Cadillac CTS
Joined
·
6 Posts
I had this happen to me when I purchased my CTS. It costed me $1800 to fix. Now I am fixing the fuel pump costing me $800. Other than that I haven't had any problems and cars break down sometimes. Just got to suck it up. I think all together though the CTS is a great smooth ride. And worth every penny. Just make sure you change the oil about every 3,000 miles and do the tune ups and this car should last you for awhile. Mine has 156K right now and still going.
 

·
Registered
Joined
·
13 Posts
Got the message reduced engine power and took it to the shop and they did all the tests. Said it was my ECM and thy it is very common for 2003 cts. Took it to Cadillac and they reset the computer, updated hardware and they said its fixed? What do you guys think? Sounds kind of fishy...
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
Got the message reduced engine power and took it to the shop and they did all the tests. Said it was my ECM and thy it is very common for 2003 cts. Took it to Cadillac and they reset the computer, updated hardware and they said its fixed? What do you guys think? Sounds kind of fishy...
are you just putting the same reply in as many threads as you can find?
 
  • Like
Reactions: X Rolls-Royce

·
Registered
2003 CTS
Joined
·
114 Posts
I was told the ECM doesnt have anything to do with the Key being stuck or the shifting of the car, i am really getting lost.... someone help out?!

My problems... Wont shift(no indicator yellow led light), Key stuck, temp & gas dont work, power steering works after 10 MPH but it starts...???? HELP PLZZ.

OBD says U1000c to almost everything and ECU/ECM has NO DATA?
 

·
Registered
2006 CTS-V
Joined
·
4,969 Posts
ECM with no data means its not being detected \ losing connection to it. Check the fuse and then wiring to it, and then most likely, you'll have to replace it.

I remember I had no data on the door module, and it ended up being a blown fuse.
 

·
Registered
03 CTS 3.2L (Sold) / 09 CBR 600rr /2014 GMC Sierra
Joined
·
7,872 Posts
I was told the ECM doesnt have anything to do with the Key being stuck or the shifting of the car, i am really getting lost.... someone help out?!

My problems... Wont shift(no indicator yellow led light), Key stuck, temp & gas dont work, power steering works after 10 MPH but it starts...???? HELP PLZZ.

OBD says U1000c to almost everything and ECU/ECM has NO DATA?
please stop putting the same comment in a bunch of threads at the same time....its bumping old threads and mostly just me and people who arent even on here anymore getting 10 emails in a row all with you post.
use 1 thread.

and yes, it sounds like your ECM. the u 1000 is network connection, if its not getting the info it doesnt know what to do with it.
 
1 - 13 of 13 Posts
Top