Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
CTS
Joined
·
148 Posts
Discussion Starter #1
Hi,

I just got a 2003 CTS less than 2 weeks ago. My question is that in the last few days my TC and ABS light have come on at the same time. I press the TC button and nothing happens. Also, it only comes off when i turn the car of and turn it back on. I have not idea what triggers the light to come on either. Please Help.:bonkers: :bonkers: :bonkers: :bonkers:

:banghead:
Greg - NYC
 

·
Registered
CTS
Joined
·
1,485 Posts
Cadi2004 said:
Hi,

I just got a 2003 CTS less than 2 weeks ago. My question is that in the last few days my TC and ABS light have come on at the same time. I press the TC button and nothing happens. Also, it only comes off when i turn the car of and turn it back on. I have not idea what triggers the light to come on either. Please Help.:bonkers: :bonkers: :bonkers: :bonkers:

:banghead:
Greg - NYC
Sounds like a bad speed sensor on a wheel? Need to get the dealer to diagnose it.
 

·
Registered
2003 3.2L Luxury Raven Black
Joined
·
120 Posts
I had recently purchased a 2003 CTS as well and the same problem with both the TC / ABS lit coming on too it to the dealer and they replaced a bad sensor in the wheel area. Just curious how many miles on your CTS and how much did you pay$$$?

Thanks
Dave (Braz60)
 

·
Registered
CTS
Joined
·
148 Posts
Discussion Starter #7
Braz60 said:
I had recently purchased a 2003 CTS as well and the same problem with both the TC / ABS lit coming on too it to the dealer and they replaced a bad sensor in the wheel area. Just curious how many miles on your CTS and how much did you pay$$$?

Thanks
Dave (Braz60)
i paid 20k, and that car had 35,500 miles on it. How long did it take them to replace the sensor
 

·
Registered
'04 Escalade EXT
Joined
·
352 Posts
i ahd this problem when i first bough mine with 23,000 on it. It was the right front wheel speed sensor. dont remember the part number as it was about 6 months ago. It was covered under warranty so i hope yours is still valid. have no idea what they would charge, but it did only take a short while. I dropped it off before work, so i don't know when they got to it but it was done at 11 and he said it was any easy fix. There should also be an error code in the diag.
 

·
Registered
03 CTS
Joined
·
82 Posts
I had that problem a couple of weeks ago. The ABS and T/C lights came on stayed lit. I stopped at the next red light, shut the car off, turned it back on and they went out as normal. Never has done it again. I happened to take the car in for some warranty stuff; battery, rear backup light panel moisture, driver seat leather cracking, had the dealer check that issue and they told me the diagnostics didn't tell them anything.
They needed to order the panel and leather so I'll mention the speed sensor when I take it back. Thanks!
 

·
Registered
2003 3.2L Luxury Raven Black
Joined
·
120 Posts
Cadi2004 You mentioned you payed 20K was this out the door? If so you got a great deal. I Payed 19K from a private owner, car had 45k mikes on it still under warranty.
 

·
Registered
CTS
Joined
·
148 Posts
Discussion Starter #12
good to know i got a great deal. i have an appiontment with the dealer on 1/04/05 to check the tc/abs lights. The car is still under warranty.
 
1 - 12 of 12 Posts
Top