Cadillac Owners Forum banner

1 - 20 of 32 Posts

·
Registered
2003 Cadillac CTS
Joined
·
18 Posts
Discussion Starter #1
I have been having this problem since about January. The progression usually goes as follows. The car will behave perfectly fine most of the time, then implode. First the transmission will begin to shift very hard, then the idle RPM's will be way too high (spec is 650, I will get around 1100), sometimes the center stereo screen will show "Service Idle Control", then any short amount of time later the center stereo screen will show "Reduced Engine Power" and the car will basically cut all gas except enough to keep the engine idle. This will happen at any type of driving whether stopped at a stop light or going 70 on the interstate (which really sucks).

I have recently found that I can temporarily fix the problem by pressing F1 and F6 on the stereo to enter the diagnostic center and quickly hit "Clear All Codes". As soon as the codes clear, my fuel comes back online. It is the craziest thing that I am able to do this while going 70 on the interstate. I have taken the car in numerous times to the dealership and all they can do is reprogram the computer which will fix it for a short time. Last time they told me to replace the throttle body and I am desperate so I did. This actually seemed to increase the frequency of the problem.

Unfortunately there were more error codes on the computer, but I cleared them to get my fuel to come back. The one reoccuring code seems to be:

P0700C

This problem is killing me and I appreciate any help people are willing to offer.
 

·
Registered
03 Caddy CTS
Joined
·
1,028 Posts
I have been having this problem since about January. The progression usually goes as follows. The car will behave perfectly fine most of the time, then implode. First the transmission will begin to shift very hard, then the idle RPM's will be way too high (spec is 650, I will get around 1100), sometimes the center stereo screen will show "Service Idle Control", then any short amount of time later the center stereo screen will show "Reduced Engine Power" and the car will basically cut all gas except enough to keep the engine idle. This will happen at any type of driving whether stopped at a stop light or going 70 on the interstate (which really sucks).

I have recently found that I can temporarily fix the problem by pressing F1 and F6 on the stereo to enter the diagnostic center and quickly hit "Clear All Codes". As soon as the codes clear, my fuel comes back online. It is the craziest thing that I am able to do this while going 70 on the interstate. I have taken the car in numerous times to the dealership and all they can do is reprogram the computer which will fix it for a short time. Last time they told me to replace the throttle body and I am desperate so I did. This actually seemed to increase the frequency of the problem.

Unfortunately there were more error codes on the computer, but I cleared them to get my fuel to come back. The one reoccuring code seems to be:

P0700C

This problem is killing me and I appreciate any help people are willing to offer.
This is just a break down of the codes maybe it will help you to pin point the problem
P0700 - Transmission Control System Malfunction
P0701 - Transmission Control System Range/Performance
P0702 - Transmission Control System Electrical
P0703 - Brake Switch Circuit Malfunction
P0704 - Clutch Switch Input Circuit Malfunction
P0705 - Trans Range Switch Circuit
P0706 - Trans Range Switch Performance
P0707 - Transmission Range Sensor Circuit Low Input
P0708 - Transmission Range Sensor Circuit High Input
P0709 - Transmission Range Sensor Circuit Intermittent
P0710 - Transmission Fluid Temperature Sensor Circuit Malfunction
P0711 - TFT Sensor Circuit Range/Performance
P0712 - Transmission Fluid Temperature (TFT) Sensor Circuit Low Input
P0713 - Transmission Fluid Temperature (TFT) Sensor Circuit High Input
P0714 - Transmission Fluid Temperature Sensor Circuit Intermittent
 

·
Registered
2003 Cadillac CTS
Joined
·
18 Posts
Discussion Starter #3
I think I am going to replace the Transmission Control Module, that sounds kinda like the code description. Does this make sense?
 

·
Registered
2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
Joined
·
6,414 Posts
i think that would correct your problem...please keep us updated...
 

·
Registered
2003 Cadillac CTS
Joined
·
18 Posts
Discussion Starter #5
I will be replacing the TCM in the morning, wish me luck because I am about out of ideas.
 

·
Registered
2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
Joined
·
6,414 Posts
if you dont mind me asking, how much did you pay for the TCM?
 

·
Registered
CTS 2003
Joined
·
19 Posts
Man. I know how you feel... I have been having the same problem!! I had to take the VP of my company back and forth to the airport... I was praying and fasting 2 days before picking him up, asking God to not let me be embarrassed by my car going into reduce power while driving...ok so I didnt really do the fasting part... so guess what happened...just when I thought I was in the clear... Im taking my VP back to the airport and in the airport tunnel it went into reduced engine power and then turned off. How embarrassing.. lol. I acted shocked, like what the heck.... after I dropped him off, all I could do it laugh and tell God what a great sense of humor he has..

I think I have figured it out!! I have a appointment with a shop tomorrow.

When this started happening, I took it right away to the cadillac dealer. I paid $125 for them to diagnose it. They said it was a malfunctioning throttle body censor... it would cost $550 for it, and it would be 4 labor hours at $125. Which both prices are a rip off. I asked the dealer why so much? He said that's how they keep the lights on....

Anyway... I just bought today, the throttle body--The reason you cant buy the censor is because on the 2003 they are one part, so you have to get the whole throttle body... anyway, so I took it to a mechanic for a free diagnosis and told him what I needed done... they are going to charge me 2 labor hours at $70. I was gonna cry when he told me... ok so maybe not cry.. but anyway.... so I called up another cadillac dealer and used spoofcarddotcom to call using another dealerships phone number..(how spoof card works, is you type in the number you are calling, then type in the number you want to show on the caller id, then you enter your number, the system calls you and when you answe it begins to call the other party with the number that chose to show on the caller id).. so then I got transferred to parts and told them I was a dealer need to order parts, I ordered the throttle body and CPS--because everyone on this forum recommends it to fix the morning crank)

Guess how much they charged me.... $320 for the throttle body... I saved $230bucks..and $23 for the CPS... when I picked up the parts, I looked like a runner, put on my dickies short and shirt in black tennis shoes and wore a hat from Toyota... which was the dealership he though I was from...(maybe it was a little shady... but for $500 would you do it? thats how much I saved) .....ok so I am scheduled to take my car in tomorrow-Saturday at 11am. I will let you know if it fixed my problem!!
 

·
Registered
2003 CTS "Ebony Maria" 2005 Cadillac STS "Grace"
Joined
·
6,414 Posts
I just have a sense of humor just like you do. Only it's on a different plain of humor I guess. :sneaky:

KOT
whether the story is real or not, it was creative...lol...give him a little credit for that...:histeric:
 

·
Registered
2003 Cadillac CTS
Joined
·
18 Posts
Discussion Starter #13
I believe fastforward. The dealership wanted over $600 for a new throttle body and they wanted to charge me over $500 in labor. I ended up buying the throttle body from a salvage yard with 30K miles for only $150. Then I installed it myself (a person with very little mechanical experience, especially in these new cars) and the install took me 25 minutes, including clean up. It is amazing what these dealerships think they are getting away with.

if you dont mind me asking, how much did you pay for the TCM?
The dealership wanted $380 for the TCM. I ended up buying it from Schram Auto here in Michigan. It is a used parts dealer that largely operates on the web through schramauto.com. You can always just call them also for nearly any GM part, they are great. The part ended up costing me $75 and looks like it is in great condition.
 

·
Registered
CTS 03
Joined
·
1,765 Posts
I like his story and I've done something similar when working on a project call a vendor and tell him I'm from Motorola ask for an engineering sample, some times they send it to you for free.

Keep us updated. BTW is there a charge to use that spoofcarddotcom ?
 

·
Registered
Joined
·
465 Posts
FYI;

I replaced my TCM last week after multiple incidents involving on-again, off-again hard shifting [w/P0700 codes]. The install was easy and quick. Dealer price to me was $187.00. Tranny shifts like new again.

ALSO: my 03 cts was cranking abnormally [long cranks before engine start-up/ idle]. Code was throwing a faulty camshaft position sensor [high voltage]. This morning, the camshaft position sensor was replaced. Vehicle now cranks once with instant start-up/idle.
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,819 Posts
Oh, don't get me wrong. I thought the story was creative too and all. But the whole reason why I posted my post was because he made it evident that it was just a story, at least that is how I saw it. The last line, "ok so I am scheduled to take my car in tomorrow-Saturday at 11am. I will let you know if it fixed my problem!!" is what made me think he was joking around.

KOT
 

·
Registered
2003 Cadillac CTS
Joined
·
18 Posts
Discussion Starter #17
FYI;

I replaced my TCM last week after multiple incidents involving on-again, off-again hard shifting [w/P0700 codes]. The install was easy and quick. Dealer price to me was $187.00. Tranny shifts like new again.

ALSO: my 03 cts was cranking abnormally [long cranks before engine start-up/ idle]. Code was throwing a faulty camshaft position sensor [high voltage]. This morning, the camshaft position sensor was replaced. Vehicle now cranks once with instant start-up/idle.
You are right, the TCM was one of the easiest things I have ever replaced. Did you do anything special to get the computer to recognize the new TCM? Because so far it doesn't seem to have fixed any of my problems.
 

·
Registered
Joined
·
465 Posts
....Did you do anything special to get the computer to recognize the new TCM? Because so far it doesn't seem to have fixed any of my problems.
Sorry to hear that.

I didn't do anything special. I just made sure to clear the code(s) immediately after the install.

Are you having any long cranking issues? What other codes are you throwing?

-Jimmy
 

·
Registered
06 CTS Sport/Luxury package
Joined
·
9,819 Posts
I bet you that is the problem. There are somethings that you can replace, like one of the computers. And the main computer does realize it until you hook up a scan tool and clear all codes from the system. Basically to force the system to relearn it self.

KOT
 

·
Registered
2003 Cadillac CTS
Joined
·
18 Posts
Discussion Starter #20
No, I am not having any issues with long cranks, but I already had the CPS replaced a while back.

As far as codes, I think I have received half the book at this point. The last round of codes was C1278, U1000, and P2101 along with a bunch of nonsense codes such as the driver side window not operating correctly and the onstar antenna malfunctioning but those immediately went away.
 
1 - 20 of 32 Posts
Top