Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JUNE's Ride of the Month Challenge!

1 - 15 of 15 Posts

·
Registered
2003 White Diamond Escalade
Joined
·
8 Posts
Discussion Starter · #1 ·
I just traded in my '05 Expedition for an '03 Escalade and I love it, but upon my drive home from Ohio to NY all 3 of the above mentioned lights came on after hitting a pothole.
Could it be a pre-existing condition that was reset by a shady used car dealer, of perhaps I jarred something loose when I hit the pothole?
Any suggestions?
 

·
Registered
03 cadillac escalade
Joined
·
11,910 Posts
um where to start the stability light might be a wheel speed sensor and i do know that there is not a tire pressure monitoring system on the 03's cause if it did i wound know cause i have a 03 but it might have jarred something to cause the service stability system message to display in the dic and the tc off light to turn on i know it has happened but went away after restarting but since you went from ohio to new york to might be the brake system is getting to hot due to use on the long trip i seen happen on my moms' chrysler town&country van sometimes during a long road trip i has done it on my escalade twice so far and hasn't happen since but i will repeat the 03 escalades don't have tire pressure monitoring system the 04 and up got that
but if the message displays again post on here again good luck and good buy i know you will love the escalade btw did you get the all wheel drive model you can tell by your engine if it is a 6.0 you have all wheel drive it is fun to pull up to a mustang and leave it in the dust while the driver is wondering how the hell did he get beat by a suv little does he know it has a corvette inspired engine under the hood i love my caddy
 

·
Registered
2003 CADILLAC ESCALADE
Joined
·
8 Posts
I have the same problem as the OP. My wife just informed me that the abs, traction control, & service stability came on? Escalade is an 03 with 100,000 on the clock. Recent repairs (about 2k miles ago) were front wheel hubs rear rotors & pads, & air ride compressor. I've read on the forum to check the grounds on the EBCM & possibly wheel sensors? I'm currently out of town & am worried if I have my wife drop it off at the dealer she will get taken advantage of please help! I wont be near the truck till the 20th & want to know if I should tell my wife to park it till then.

any help would be greatly appreciated,
Idel
 

·
Registered
03 cadillac escalade
Joined
·
11,910 Posts
no i don't think it will hurt it i have seen these lights come on other cars and trucks and mainly it cause of heavy brake usage from going up and down steep roads mine has done this one time so far and it was on a long trip many steep hills over the 300 mile round trip and when i got to the place i was going to i then went to another place to go and get some food and come back out and got in as i always do and about 30 seconds after i start it up these same lights come on due to the heavy brake use from the hilly roads i was driving on it don't hurt it one bit to drive it like this but if you have the lights staying on then get it to the dealer soon the three lights is the abs light traction control off which a tire with tc and slash over it and the service stability message being displayed on the dic
 

·
Registered
2003 CADILLAC ESCALADE
Joined
·
8 Posts
ABS, Traction Control & Service Stability lights all came on at once?

Thanks for the reply. I've read several threads where people said the same as yourself about the up hills & down hills etc.. But the truck is in south Texas (Flat lands) small town driving not to much stop & go. I would have her take it to the dealer, but I've had nothing but bad experiences with them. I am gonna have my wife take it to a local shop to pull the codes, then hopefully I can post them here to get some guidance. I've read that it could possibly be the ABS wheel sensors? or EBCM grounds or the unit itself? but would any of the these cause all three lights ABS, Traction Control, & Service Stability Control to come on?

Idel
 

·
Registered
03 cadillac escalade
Joined
·
11,910 Posts
if a wheel sensor is bad or is going bad it will cause the same set of lights to come on cause they all use the sensors on the wheels but here is what erks me the sensors are built into the wheel hubs so you have to replace it as a whole i am sure unless someone has replaced them before but as far as the grounds i don't know ask your wife and see how many times the lights come on or if they come on and stay on but i am really thinking it is a wheel sensor either going bad or it is bad
 

·
Registered
2003 CADILLAC ESCALADE
Joined
·
8 Posts
Re: 2003 ABS, Traction Control & Service Stability lights all came on at once?

I talked to my wife, she said the lights turn on & stay on after she turns on the truck. I did have the front hub bearings replaced about 2K miles ago & noticed there were no sensors attached to them. I checked ebay & found these:
http://cgi.ebay.com/ebaymotors/ACDE...Accessories&hash=item19c52e77b7#ht_1580wt_941

I think I'll take your advice & have my wife take to the dealer to pull codes & diagnose but thats it.

Thanks again,
Idel
 

·
Registered
2003 CADILLAC ESCALADE
Joined
·
8 Posts
Well now my wife said the lights went off & while she was driving as she was about to apply the brakes & the traction control active came on on the (DLC). The brake pedal vibrated like the truck was loosing traction, then immediately after all 3 (Abs, T/C, Service Stability Control) lights turned off. Weird????? She's taking it in tomorrow.
 

·
Registered
03 cadillac escalade
Joined
·
11,910 Posts
it is the wheel sensor it will make the truck do funny things i know cause it is makeing the abs and traction control think that a wheel is locking up mine did this in the winter but it was due to the ice and snow not my wheel sensor but it is not fun to have it done to you when it is winter on a snow and ice covered road going up a hill but it has only done it one time as far as the traction control message showing in the d.i.c. and whenever the traction control does kick in it will make you feel like you are loseing control but you really ain't loseing control good luck getting it fixed have both front wheel sensors checked to be on the safe side
 

·
Registered
2003 White Diamond Escalade
Joined
·
8 Posts
Discussion Starter · #12 ·
um where to start the stability light might be a wheel speed sensor and i do know that there is not a tire pressure monitoring system on the 03's cause if it did i wound know cause i have a 03 but it might have jarred something to cause the service stability system message to display in the dic and the tc off light to turn on i know it has happened but went away after restarting but since you went from ohio to new york to might be the brake system is getting to hot due to use on the long trip i seen happen on my moms' chrysler town&country van sometimes during a long road trip i has done it on my escalade twice so far and hasn't happen since but i will repeat the 03 escalades don't have tire pressure monitoring system the 04 and up got that
but if the message displays again post on here again good luck and good buy i know you will love the escalade btw did you get the all wheel drive model you can tell by your engine if it is a 6.0 you have all wheel drive it is fun to pull up to a mustang and leave it in the dust while the driver is wondering how the hell did he get beat by a suv little does he know it has a corvette inspired engine under the hood i love my caddy
Thanks for the reply!.....It ended up needing a few things..lft & rt front hub bearing/abs sensors, rear pads,rotors & backing plates, perking brake kit, among some other steering parts that annoyed me..IE Pitman arm,Idler arm and steering shaft.
lol.....Now I have noticed something that I had with my '02 Yukon...the infamous hard down shift and gear rash.
Any suggestions on if a tranny flush will help, or should I just deal with it and expect to eventually replace or rebuild the tranny?
 

·
Registered
2003 White Diamond Escalade
Joined
·
8 Posts
Discussion Starter · #13 ·
if a wheel sensor is bad or is going bad it will cause the same set of lights to come on cause they all use the sensors on the wheels but here is what erks me the sensors are built into the wheel hubs so you have to replace it as a whole i am sure unless someone has replaced them before but as far as the grounds i don't know ask your wife and see how many times the lights come on or if they come on and stay on but i am really thinking it is a wheel sensor either going bad or it is bad
Yep....whole hubs....way expensive...400.00 each.(or at least thats what Caddy banged me for them).
 
1 - 15 of 15 Posts
Top