Cadillac Owners Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
383 Posts
Discussion Starter #1
Hey you guys with 3.2L engine out there. Recently ive been noticing that my car makes weird noises when in idle. Like every 5 minutes it makes a noise like if its changing belts or something or something in stuck in the engine and its trying to push it out...lol...well i hope u guys know what im talking about, weird noises....
 

·
Registered
CTS
Joined
·
1,756 Posts
RobertCTS said:
He said it started recently which leads me to believe it's not the AC engaging.
Well, then it may be the AC not engaging...:histeric:
Seriously, good point, but it's easy to overlook something that's always been there, below thought threshold until something causes one to zero in...

Five minute intervals, or thereabouts? May just be a gentle belch, oxygen sensor needing replacement, belt, whatever... You're right, Robert, mileage may be a factor...
 

·
Registered
Joined
·
383 Posts
Discussion Starter #7
well turning the A/C off does make a diff but not that big. My car officially has 100,000 kms on it. Do you guys think could be my thermostat.

Thanks for any more info guys
 

·
Registered
Black the Darkside
Joined
·
22,415 Posts
CadiKing2006 said:
well turning the A/C off does make a diff but not that big. My car officially has 100,000 kms on it. Do you guys think could be my thermostat.

Thanks for any more info guys
That's about 62,000 miles for us Yankees:yup: That's not really a lot of miles. Does it only do it at idle or at speed? I would think the ECU would send a message to the DIC if your thermostat was sticking.
 

·
Registered
Joined
·
1,764 Posts
Have you ever changed any of your belt pulleys? If not, I'd check them as their bearings do fail over time; if they are making noise, as they are on their way out. It might also be your alternator. Lastly, check you power steering fluid level.
 

·
Registered
Joined
·
126 Posts
My car made some "clanking" noises before, it ended up being a pulley, I believe it was the serpentine pulley? It was the one located on the top left side. It stating making that noise...it got worse and worse until finally one morning I turned it on...and it made an awfull sound, so I turned it off within a seconds...the damn thing finally broke...I had it towed and they finally fixed it. Can you believe this was two days after I brought her home! Of course I bought it used so, I can't complain.:thepan:
 
1 - 15 of 15 Posts
Top