Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I took the sterio of my 2002 Cadillac Seville, and then air bag , battery and tractions light are on afte I wire an aftermarket sterio. also the anti theft system is on, how to fix it?
 

·
-Administrator- 2002.5 F55 STS 2014 FWD Explorer
Joined
·
66,638 Posts
Re: instal aftermarket sterio

The original stereo sound system head unit is a necessary part of the car's serial data bus, TheftLock, and security systems.

You need to reinstall the original wiring and connectors and head unit, get the system working again then talk to the guys at Crutchfield about the correct jumper harnesses and wiring - that retains the old head unit in the trunk to run the rest of the car.
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,827 Posts
I took the sterio of my 2002 Cadillac Seville, and then air bag , battery and tractions light are on afte I wire an aftermarket sterio. also the anti theft system is on, how to fix it?
======================
there are two special harnesses/adapters that MUST be used for a successful radio swap -

do the swap without the adapters - the car MIGHT not even start/run again -

HOPEFULLY you didn't hack up the original harness -

start over -
reinstall the original radio - get everything back to "normal" -
cross your fingers -
clear all the DTC's that obviously have been set -
obtain the correct adapters -
try installing the aftermarket radio -
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Re: instal aftermarket sterio

The car starts and drive, I did not cut the original harness,. i had a female harness that I conected to the stereo, i hope I conected everything right,
the only thing now is that when I put the original radio back it does not work, excite the clock buttons.
also parking break does release anymore , I have to do it manually.
to clean all the codes could I use a simple obd II?
 

·
Master of the Dark Art of Diagnostics
Joined
·
18,827 Posts
Re: instal aftermarket sterio

The car starts and drive, I did not cut the original harness,. i had a female harness that I conected to the stereo, i hope I conected everything right,
the only thing now is that when I put the original radio back it does not work, excite the clock buttons.
also parking break does release anymore , I have to do it manually.
to clean all the codes could I use a simple obd II?
=========================
to clean all the codes could I use a simple obd II?
our cars have a built-in scanner that will display all stored codes -
MUCH better than MOST hand-held scanners -

to check for DTC's - Diagnostic Trouble Codes -
if you don't know how - go here -
http://www.cadillacforums.com/forums/cadillac-seville-cadillac-eldorado-forum/138258-how-pull-codes-dtcs.html

post any codes you have -
ALONG WITH THEIR DEFINITIONS -

include whether they are C-Current or H-History -

for code definitions - go here -
http://www.cadillacfaq.com/faq/answers/dtccode.html


here is a how-to video -
https://www.youtube.com/watch?v=0PQhWmlbG_A

------------------------
after checking/clearing the codes -
if the radio and other electronic components still don't work -
check the fuses - BOTH under the hood and under the back seat -
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Re: instal aftermarket sterio

I put the original back looks like everything went back to normal except the parking break. So what harness adapter should I use for aftermarket radio
 
1 - 8 of 8 Posts
Top