Cadillac Owners Forum banner

1 - 11 of 11 Posts

·
Registered
2002 Cadillac escalade
Joined
·
1 Posts
Discussion Starter #1
Have had this truck for about a month. Runs great, two owner, well taken care of...This seems like an odd issue but sometimes I put the key in and truck does nothing, security light is on, lights on, radio will come on, no other sounds, no clicking nothing..I thought that my key chain might be interfering with whatever device is in the key and the ignition so I took those off. It worked for a while, now this morning it happened again. It is very cold here and when I realized it would not start after several tries I waited about 10 minutes and put key in again. Truck started right up. I have had the battery, alternator, starter checked-everything fine there. No check engine light. It seems to be something with key?? Also checked with Cadillac dealership service department. They said maybe a sensor/chip issue??? Any suggestions?
 

·
Registered
03 cadillac escalade
Joined
·
11,902 Posts
ms.pat said:
Have had this truck for about a month. Runs great, two owner, well taken care of...This seems like an odd issue but sometimes I put the key in and truck does nothing, security light is on, lights on, radio will come on, no other sounds, no clicking nothing..I thought that my key chain might be interfering with whatever device is in the key and the ignition so I took those off. It worked for a while, now this morning it happened again. It is very cold here and when I realized it would not start after several tries I waited about 10 minutes and put key in again. Truck started right up. I have had the battery, alternator, starter checked-everything fine there. No check engine light. It seems to be something with key?? Also checked with Cadillac dealership service department. They said maybe a sensor/chip issue??? Any suggestions?
It sounds like the starter is failing
 

·
Registered
2007 Escalade Base Black
Joined
·
248 Posts
do you have a spare key? if so, try it (to rule out key failure)...maybe years of heavy keychains wore out the ingnition cylinder...had that happen on a previous car of mine
 

·
Registered
03 Escalade AWD 6.0L
Joined
·
107 Posts
Have had this truck for about a month. Runs great, two owner, well taken care of...This seems like an odd issue but sometimes I put the key in and truck does nothing, security light is on, lights on, radio will come on, no other sounds, no clicking nothing..I thought that my key chain might be interfering with whatever device is in the key and the ignition so I took those off. It worked for a while, now this morning it happened again. It is very cold here and when I realized it would not start after several tries I waited about 10 minutes and put key in again. Truck started right up. I have had the battery, alternator, starter checked-everything fine there. No check engine light. It seems to be something with key?? Also checked with Cadillac dealership service department. They said maybe a sensor/chip issue??? Any suggestions?
The security light comes on when you try to crank it? When you have the key turned to the start position - does it stay on, or go out? If it's staying on and nothing is happening, it's likely that there is a factory immobilizer (Passlock?) that's acting up.
 

·
Registered
Joined
·
24 Posts
Buuuuump. My 2002 escalade is doing this right now. when I click the key forward, the dash looks normal, no security light comes on. It showing just a touch over 12V. When I move the key forward to engage nothing happens. Any ideas?
 

·
Registered
2004 ESV
Joined
·
856 Posts
Is the fuel pump priming when you put the ignition to "run"? And by "nothing happens", are you saying there are no clicks from the starter? How old is the battery? Does the Escalade get driven regularly or is this a vehicle that only gets occasional usage?
 

·
Registered
Joined
·
24 Posts
Is the fuel pump priming when you put the ignition to "run"? And by "nothing happens", are you saying there are no clicks from the starter? How old is the battery? Does the Escalade get driven regularly or is this a vehicle that only gets occasional usage?
Battery is new. Volts are good. Just drove it today no issue, now theres no clicks. Dash looks fine, no security issues that I can tell of, I cant hear if the pump is priming or not.
 
1 - 11 of 11 Posts
Top