Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
2002 Deville
Joined
·
15 Posts
Discussion Starter #1
Caddy has been driving sluggish, no power , i got the Service transmission on the DIC but no codes besides the P0741-TCC Stuck which ive had since I bought the car 8 yrs ago, & the P0420-Catalytic Cbvertorr because a muffler shop got me a year ago & installed an aftermarket which is causing the code to pop up. Well yesterday I tried driving it & there was absolutely no power i couldn't get pas 10mph, the car felt like it was bucking & finally got a P300 (MISFIRE)
and a P1381 - Where can I start to figure out the problem? I looked this up but i got so many different things that it could me.. Any suggestions would be sooo appreciated.
 

·
2004 Deville base
'05 SRX N*/AWD, Vetts/Birds/Trucks
Joined
·
393 Posts
How long/old are the sparkplugs/how many mi on the car, etc. Kinda hard to wild @ss guess at stuff.
Maybe pull/inspect/or replace plugs/coils and check/clean wiring and grounds associated with it all.

How did it run/mpg 90/30/7/3 days ago? Getting worse,,,or just fell off a cliff yesterday?
Fuel,,,new/old/same filling station or not/filter changed last.

P1381 could be the crank sensor, or wiring to it, or just some or combinations of this other stuff causing the trip/light
It all works together, has to work right.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
18,913 Posts
I would start with the fuel injectors -

use a stethoscope - or similar - to listen for the very distinct CLICK each time the injector fires -

I suspect one or more stuck injectors - dumping fuel -
probably fouling one or more plugs -
thus CAUSING the P0300 misfire code -
thus CAUSING the cat to fail -
and the failed cat to set the P0420 code -

never saw - or even heard of a P1381 code before -
fix the misfire and it MIGHT go away too -
 

·
Registered
2002 Deville
Joined
·
15 Posts
Discussion Starter #4
How long/old are the sparkplugs/how many mi on the car, etc. Kinda hard to wild @ss guess at stuff.
Maybe pull/inspect/or replace plugs/coils and check/clean wiring and grounds associated with it all.

How did it run/mpg 90/30/7/3 days ago? Getting worse,,,or just fell off a cliff yesterday?
Fuel,,,new/old/same filling station or not/filter changed last.

P1381 could be the crank sensor, or wiring to it, or just some or combinations of this other stuff causing the trip/light
It all works together, has to work right.
Its been running shitty, forgt to add that my brake lines were leaking back in September, I thought i needed a brake fluid flush cus my brake fluis was really black, turns out i was leaking brake fluid, dont know how I made it home. I believe my spark plus were replaced about a year or 2 ago, coil packs seem to go out every year on this car. Car has 215,000
 
1 - 4 of 4 Posts
Top