Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
2000 Cadillac STS
Joined
·
3 Posts
Discussion Starter · #1 ·
The car fires right up then almost immediately dies. It started out just doing this once in a blue moon when it was warmer out and my dad replaced the MAF and we thought we had fixed it. Now it does it almost everytime the car is cold. Im staring to get sick of having a foot on the brake and the gas at stoplights. Does anyone know how to fix this?
 

·
Registered
04 Deville, 11 DTS Premium, 00 Deville (sold), 02 Deville (sold)
Joined
·
2,691 Posts
Pull the codes per the sticky at the top of the Seville page titled "How to pull codes" post the codes and their definition back to this thread. Have you cleaned the Throttle Body and IAC valve lately?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
73,084 Posts
Your Dad replaced the MAF - $145 down the drain - Make sure that the intake ducting clamps (3) are tight and that the air intake resonator is properly installed: ANY air leak from the MAF to the throttlebody will cause crazy idle and mixture problems.

Consider this to make your life (and air filter changes/transmission fluid checks) easier.
 

·
Registered
2000 Cadillac STS
Joined
·
3 Posts
Discussion Starter · #4 ·
i just went out to look up the codes but there isnt any. after about the 5th try it spudered and stay started on its own. however the rpms went from about 500 to 1500 about 5 times before staying around 700. ive also noticed when im driving it sometimes when im cruising and let off the gas the rpms stay in the same place and dont come down until after i brake but still stay higher than idle? and no we havnt cleaned the throttle body or IAC valve
 

·
Registered
04 Deville, 11 DTS Premium, 00 Deville (sold), 02 Deville (sold)
Joined
·
2,691 Posts
i just went out to look up the codes but there isnt any. after about the 5th try it spudered and stay started on its own. however the rpms went from about 500 to 1500 about 5 times before staying around 700. ive also noticed when im driving it sometimes when im cruising and let off the gas the rpms stay in the same place and dont come down until after i brake but still stay higher than idle? and no we havnt cleaned the throttle body or IAC valve
I would start off giving the throttle body and IAC valve a good cleaning per the tutorial in the tech tips section of the board. It sounds like it may be gummed up and sticking.

http://www.cadillacforums.com/forums/cadillac-tech-tips/167181-tb-iac-idle-air-control-valve.html
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
73,084 Posts
IAC - 2 screws or bolts. Remove it, make sure the silicone O-ring comes out with it. Use hobby pipe cleaners and throttlebody spray to clean out the bore in the throttlebody - also carefully clean the "top hat" plunger on the IAC itself. Light smear of engine oil on the O-ring when you put it back together.
 

·
Registered
2000 Cadillac STS
Joined
·
3 Posts
Discussion Starter · #8 ·
ok ill give that a try tomorrow. hopefully its the last thing i have to do on this thing for awhile. i replaced the engine in the first week of october(due to mother running it out of oil) then hit a deer two weeks after that and i just got finished repairing that yesterday. now i just need a passenger side headlight and i should be good to go. thanks for the help guys
 
1 - 8 of 8 Posts
Top