Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
2009 CTS PI
Joined
·
15 Posts
Discussion Starter #1
Freaking out, I just bought a mint condition used 2000 DHS, only issueit had the erratic fuel gauge issue. So I disconnected the battery, removed the fuel pump assembly, fixed the sensor and reinstalled the unit to my dismay when the damn thing wouldn't start, it cranks, but won't start. I have had two mobile mechanics out to the house. Neither of which could figure out why. One said that it was to do with the security system shutting down power to the fuel pump but the telltale light is acting normal. It's not flashing rapidly or staying on. It goes off when the key is turning and stays off. All the fuses and relays are fine. Does anyone have any suggestions. I have tried the key in the door gimmick as well as turning the key to the on position for 3 tem min cycles but that didn't work and the security light wasn't on for any of it.
 

·
Registered
70 Deville 77 Fleet 78 Seville 92 Deville 03 Deville
Joined
·
3,310 Posts
So the 2 mechanics detected no fuel pressure? It has to be a problem with the fuel pump install or a bad fuel pump. Usually there is some kind of connector that is accessible to verify power to the fuel pump. I haven't had to deal with this generation fuel pump yet. Is the fuel gauge working now?
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,458 Posts
The fuel pump should do a 2 second run-prime at Key: ON, then run constantly during crank - as the engine catches and comes up past about 450 rpm to the normal idle sequence the fuel pump latches to RUN for the entire time of that drive cycle.

Open the fuel door, ask an assistant to turn the key on and you stick an ear in the fill pipe - did the pump do the 2 second prime ? If not, you have either pump, fuse, or wiring harness problems.

If you did not replace the entire fuel pump/level sender/tank pressure assembly, that might be your problem right there.

In the 2000 engine the fuel pressure test port is on the (looking at the engine over the radiator) left rear corner of the fuel rail - the black plastic tire valve cap.
 

Attachments

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,783 Posts
If the car was working before you "removed the fuel pump assembly, fixed the sensor and reinstalled the unit", I think it's pretty obvious where he problem lies.
I'd heed AL & Earl's advice.
 
1 - 5 of 5 Posts
Top