Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
2000 Deville DHS
Joined
·
33 Posts

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,254 Posts
The car has done its thing again. I have power like radio, interior light but when I turn the switch nothing. It is doing exactly like in did before but *minutes later I was able to crank the car then but not now.. When I cranked this time it fired up and quickly shut off and now nothing. Any ideas????*

Previous thread http://www.cadillacforums.com/forums/cadillac-deville-1985-2005-including-1985/676521-security-light-issue-2000-dhs.html#post14050721
----------------------------------------
When I cranked this time it fired up and quickly shut off
and now nothing. Any ideas?

just a WAG - faulty ignition switch -
 

·
Super Moderator
2003 Deville Base
Joined
·
4,792 Posts
sorry. I replied before I read your previous thread. You're already ahead of any advice I could give.
 

·
Registered
2000 Deville DHS
Joined
·
33 Posts
Discussion Starter #4
Ok we got it to crank and it's running better than ever right now there was a loose main power lead going to the fuse box under the hood we do think that the ignition switch is faulty I'll be getting a new one from the dealer soon since they have a recall out on it for ignition keys falling out like mine does sometimes. Thanks for the tip on the switch we think that it and the connection were part of the reason for the electrical problems. I'm crossing my fingers I'm running out of money and this is my daily driver. For only 82,000 miles and pristine looking condition this deville is drainin my wallet.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,254 Posts
Ok we got it to crank and it's running better than ever right now there was a loose main power lead going to the fuse box under the hood we do think that the ignition switch is faulty I'll be getting a new one from the dealer soon since they have a recall out on it for ignition keys falling out like mine does sometimes. Thanks for the tip on the switch we think that it and the connection were part of the reason for the electrical problems. I'm crossing my fingers I'm running out of money and this is my daily driver. For only 82,000 miles and pristine looking condition this deville is drainin my wallet.
=====================
since they have a recall out on it
for ignition keys falling out like mine does sometimes

the current recall is a JOKE -
and will NOT cover your worn out lock cylinder -

it is a tiny plastic piece that fills the oval cutout on the key -
and a tiny keyring just big enough to retain the key to the fob -
 

·
Registered
2000 Deville DHS
Joined
·
33 Posts
Discussion Starter #6
Ok thank for telling me before I got it done that would've been a waste of time, I guess 8ll just buy a new switch and get all the locks rekeyed for a few new ignition keys since I need some more anyway.
 

·
Registered
2000 Deville DHS
Joined
·
33 Posts
Discussion Starter #7
SOLVED!!! I didnt want to post a false fix so i waited a littlewhile to make sure it was. I had a couple weeks off so I decided to tear the car to pieces to find my issue I was sire it was a loose connection or ground so I checked them all and found quite a few but coyldent get it to start untill the last one was fixed, the main power connection to the under hood fuse box was loose and missing the nut that held it down causing my no start condition. The bring smell has not came back so I'm hoping the connections I fixed in the cabin were causing it. Thanks for all the help yall have gave me to fix my baby.
 
1 - 7 of 7 Posts
Top