Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
All, My 125K miles DHS was taken on a 1K mile trip after changing the plugs. It ran great on the trip averaging 24.3 MPG. However when I returned, 10 miles after fueling up I accelerated out of a light and lost power. The engine was rough and the service engine soon light came on. I pulled over in a quarter mile and the engine was smoking slightly. I added a quart of oil just in case and restarted after about 20 minutes. The engine was smooth and I babied it home (another 15 miles). the next day I changed the oil and looked for anything obvious that might have caused the smoking and only found the typical slow oil pan leak. When I gave it a 5 mile test run to the store it ran fine. On my way back onto the freeway I floored it and it lost power and ran rough again. I pulled over and shut it down. after a minute I restarted it and it was still running rough. Shut it down again and set for 10 minutes and when I restarted it this time it was sill running rough. I drove it slowly home and let it sit a week. When I started it again it ran smooth for a short 2 mile test run but I was light on the throttle the whole time. Anyone have any ideas?
 

·
Registered
09 cadillac cts4 09 yukon Denali
Joined
·
194 Posts
If you had check engine light you should have a code.
I think you can pull codes off your model from dash. You could Google abd watch video on hiw to get codes from your Cadillac
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,863 Posts
start by checking for DTC's - Diagnostic Trouble Codes -
if you don't know how - go here -

post any codes you have -
ALONG WITH THEIR DEFINITIONS -

include whether they are C-Current or H-History -

for code definitions - go here -


here is a how-to video -
 

·
Registered
'93 SedanDeville 60 Special
Joined
·
232 Posts
Possible got bad gas on last fillup ?

Know more if reporting DTCs have tripped such as lean fuel trims, etc ?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Thanks everyone, I pulled the codes and there were only those associated with my clicking vent actuator. Also the Low Oil level light never came on however I verified it's functional when I changed the oil. I expected that it would have had some fault codes but I was pretty quick to shut the engine down when it flashed. Perhaps I should let it run longer. I'll see about replacing the fuel filter - any recommendations for a decent replacement?
 

·
Registered
2002 Deville and 2009 DTS
Joined
·
529 Posts
In my experience, when the 2002 caddy and 2009 Caddy ran rough, it was one of the coils. SEL did not come on.

Otherwise, I would suspect something like Idle Control Valve, MAF Sensor, etc... I would clean those first before replacing.
You could have an issue with fuel pressure. Hence, try changing the fuel filter first.

The "smoking"- did it smell like burning, or could it be coolant steam?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
In my experience, when the 2002 caddy and 2009 Caddy ran rough, it was one of the coils. SEL did not come on.

Otherwise, I would suspect something like Idle Control Valve, MAF Sensor, etc... I would clean those first before replacing.
You could have an issue with fuel pressure. Hence, try changing the fuel filter first.

The "smoking"- did it smell like burning, or could it be coolant steam?
The smoke came from between the firewall and the engine closer to the drivers sise of the car after I took it out and it exhibited the prior characteristics. This time I ran it in this condition long enough I got the following Current codes: IPM B0249, B0429; PCM P0300, P1360 and History codes: IPC U1016, IRC U1016, MSM B1860. The car has sat for 6 months while I was deployed and now need to dig back into this.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,863 Posts
The smoke came from between the firewall and the engine closer to the drivers sise of the car after I took it out and it exhibited the prior characteristics. This time I ran it in this condition long enough I got the following Current codes: IPM B0249, B0429; PCM P0300, P1360 and History codes: IPC U1016, IRC U1016, MSM B1860. The car has sat for 6 months while I was deployed and now need to dig back into this.
=================
codes are meaningless without their DEFINITIONS -
and no one has them all memorized -

go here for the best list of Cadillac code definitions -
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Thanks for the link. The descriptions for the current codes are:
-PCM P0300 engine misfire detected
-PCM P1360 ignition coil group 2 control circuit
-IPM B0249 heater/defrost/AC door range error
-IPM B0429 temp control #3 rear circuit range/performance
And the history codes are:
-IRC U1016 loss of class 2 communication with VCM
-IPC U1016 loss of communication with VCM.
Also I forgot to respond to the question regarding the smell of the smoke. It was not a coolent smell but possibly electrical and something else. Thanks all for the help
 

·
Registered
Joined
·
8 Posts
Discussion Starter #12
Just to close out this thread I was able to fix this problem by replacing the Block 2 Cassette (front of vehicle). The smoke was due to the rough running engine. Thanks all
 
1 - 12 of 12 Posts
Top