Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
99 STS
Joined
·
269 Posts
Discussion Starter #1
My 98 SLS, obviously has power windows...but they take FOREVER to work, id say a good 5 seconds holding them up or down before they move. Once they do spring into action they work fine, so its not a window motor problem. I dont get it, are all sevilles like this, any advice?

Secondly, there is this really gnarly sounding grating clicking noise from the rear passenger side of my car. I always assumed it was an air ride compressor of some sort, I dont really know what else it could be, but if that doesnt sound normal of if there is an easy way to quiet that bad boy down...you just let me know! haha thanks

adam
 

·
Registered
99 Seville STS, 08 STS4 N* 1SG F55
Joined
·
3,516 Posts
Do the windows work slowly from all switches or just are you just using the master in the drivers door? I would check the switch wiring and change the fuse to start, although the fact that they work OK once they move doesn't so much sound like an electrical problem, but the fact that they all do it leads me back to suspecting something electrical since that is the only common point for all 4 windows. Do the windows make any noise while you are waiting for them?

The level ride compressor is located over the right rear wheel. People have varying reactions to the noise so it is hard to tell if yours has a problem. It should normally run for 3-5 seconds when you start the car and sound like a mechanical grizzly bear farting.
 

·
Registered
Sedan de Ville, CTS
Joined
·
4,764 Posts
Do the windows work slowly from all switches or just are you just using the master in the drivers door? I would check the switch wiring and change the fuse to start, although the fact that they work OK once they move doesn't so much sound like an electrical problem, but the fact that they all do it leads me back to suspecting something electrical since that is the only common point for all 4 windows. Do the windows make any noise while you are waiting for them?

The level ride compressor is located over the right rear wheel. People have varying reactions to the noise so it is hard to tell if yours has a problem. It should normally run for 3-5 seconds when you start the car and sound like a mechanical grizzly bear farting.
CRanger, you are so good with words!! You could make money writing children's books.
 

·
Registered
99 STS
Joined
·
269 Posts
Discussion Starter #4
Ha ha, yeah a mechanical grizzly bear fart sounds about right! I'm glad I was right, I have been telling everyone that hears it its the compressor.

As for the windows, they dont make any noise what so ever, and the odd thing is, once they are moving they respond instantly... Say i hold down the window button, when it starts moving it works normally, even if i were to switch to rolling it up, it reacts instantly. Its almost like it just needs some time to warm up or something. That makes no sense but neither does my problem! haha

thanks for the help
adam
 
1 - 4 of 4 Posts
Top