Cadillac Owners Forum banner

1 - 10 of 10 Posts

·
Registered
2009 CTS-V, 607 RWHP 627 TQ 2013 SRX, 1998 Seville STS
Joined
·
170 Posts
Discussion Starter #1 (Edited by Moderator)
its a 99 STS Seville, at first it was cold air blowing for the first 25-30 miles and then i shut the car off and turned it back on a few times, now the heat is blowing not very hot at all, its blowing at i would say 60-70 degrees, if I move the dial down to 60 degrees it blows very cold air and when i put it back to 90 degrees it blows just enough warm air so you can not see the steam from my breath and that about it. No codes showed up and the vents seem to work and I can hear the vents moving and the blower kick on, just no warm or hot air. What do you guys think it could be and what can I do to try and diagnosis the issue? thanks guys..

EDIT: Your duplicate post from the duplicate thread started in seville has been deleted. please do not start multiple identical threads in different forums.
 

·
Administrator
2002.5 F55 CORSA STS, 2014 Explorer XLT FWD
Joined
·
68,438 Posts
Re: Guys, I need your help again, no heat in the car.. i'm freezing

Read the threads title before you start a new thread - you're in the 2005+ forum. I'll move this to the proper Seville forum. (2005 "STS" is the Sigma platform, not the K body.)

Also, the title will be changed to something more descriptive.

My guess, absent a HVAC system blend door fault, is that it's time for a cooling system drain and fill accompanied with a check of the purge system function. Coolant change lately ??? (Every 3 years....)
 

·
Registered
2009 CTS-V, 607 RWHP 627 TQ 2013 SRX, 1998 Seville STS
Joined
·
170 Posts
Discussion Starter #3
sorry about that, thanks for moving, Anybody have any ideas?
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,261 Posts

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
GM was using the sealant tabs in '99. Might not hurt to flush the heater core.

How long have you owned it?
 

·
Registered
2009 CTS-V, 607 RWHP 627 TQ 2013 SRX, 1998 Seville STS
Joined
·
170 Posts
Discussion Starter #6
GM was using the sealant tabs in '99. Might not hurt to flush the heater core.

How long have you owned it?
I have owned it for 2 years and only drive it in the winter, my guess is it was never flushed, its basically a winter car for me, but heat is a must. LOL Are there instructions on doing a flush?

----------

when you say heater core, do you mean the whole coolant system, including radiator? Flush it all? and how do I go about doing this? sorry, never did it before.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,781 Posts
If you are not having any cooling problems, I'd just flush the heater core. Connect an old garden hose (with the end coupler cut off) to the heater core inlet pipe, disconnect the return pipe and turn on the hose. Then reverse the flow by switching the garden hose and reverse flush. Do it at #9 & #4 if you can get at them.

 

·
Registered
1997 Cadillac STS (BOSE w/AUX In, Massage Seats, URPAS, "Z")
Joined
·
6,405 Posts
Depends how bad is it. If is kind of bad but not enough to go over the threshold...it may not.
 
1 - 10 of 10 Posts
Top