Cadillac Owners Forum banner

1 - 14 of 14 Posts

·
Registered
1997 SLS
Joined
·
47 Posts
Discussion Starter #1
I have a '99 Catera with about 98k on it. It appears to be consuming/using antifreeze and I can't figure it out. There are never any spots on the ground, the oil appears normal but there is a faint smell of antifreeze. Any suggestions as to where I should start looking for the problem?
 

·
Registered
1997 Catera
Joined
·
172 Posts
I got some...but there are already 7 pages of ideas in the 'sticky' section that repeat them and I would be plagarizing if I claimed them myself....
(hint...leaking head gasket or leaking oil cooler, or maybe from drain hose of heater core above tranny...)
 

·
Registered
1997 SLS
Joined
·
47 Posts
Discussion Starter #4
there are tons of broken pics/links in that thread.....do the oil coolers typically fail in the 99+ Cateras, or just the 97-98s?
 

·
Registered
1997 SLS
Joined
·
47 Posts
Discussion Starter #11
UPDATE: The car now leaves puddles of antifreeze at times, not always but sporatically. I haven't really been driving the car very much because of this leak and it is still nice so I am driving my fox body mustang as much as possible before the weather gets bad. I would like to get this thing fixed though. Here is a pic of the heater control piece. I haven't had the ability to access this piece while the car is actually leaking but there does appear to be "fresh" antifreeze on this piece. That antifreeze shown running down the outside of this piece in the pic isn't normal is it :) ?

 

·
Registered
1997 SLS
Joined
·
47 Posts
Discussion Starter #14
well I replaced the valve....$88 at the dealer because I didn't want to wait for one to be shipped to me just to save a few bucks....now I am holding my breath hoping that it solves the problem as a really don't want to do the oil cooler
 
1 - 14 of 14 Posts
Top