Cadillac Owners Forum banner

1 - 3 of 3 Posts

·
Registered
Seville 1998
Joined
·
1 Posts
Discussion Starter #1
Hello!

I have problem with hazard lights!

When there is no key inside lights are not blinkin, but when i push triangle button they start blinking.

When i turn key hazard lights starts blinking right away.

I changed the hazard/triangle module. It wont work.

There is 8 wires going to that module. And 1 is hot at all times i cant remember the color. but when i turn key there is 3 HOT wires.
Those 2 are green wires and i guess they are blinkers. But those wires shouldnt be HOT until i push blinker left or right!
What should i do?? im not EXPERT on these things and sorry about my english im from Finland :)
 

·
Registered
Allante 1989 export running on LPG
Joined
·
57 Posts
Are you saying the hazards wont work when the key is off. They should work at all times key in or out?
Or are you saying the Hazards are flashing all the time when the key is on regardless of if the button is pressed or not?
In the UK the dealers fitted an after market alarm to comply with some regulation, these alarms were terrible and caused all sorts of problems, I wonder if that is your issue.
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,272 Posts
Hello!

I have problem with hazard lights!

When there is no key inside lights are not blinkin, but when i push triangle button they start blinking.

When i turn key hazard lights starts blinking right away.

I changed the hazard/triangle module. It wont work.

There is 8 wires going to that module. And 1 is hot at all times i cant remember the color. but when i turn key there is 3 HOT wires.
Those 2 are green wires and i guess they are blinkers. But those wires shouldnt be HOT until i push blinker left or right!
What should i do?? im not EXPERT on these things and sorry about my english im from Finland :)
======================
the hazard module is also the flasher for the left and right turn signals -

if pushing the triangle causes all the hazard lights to flash -

and - with the ignition ON - the turn signals work properly -

what's the problem?
 
1 - 3 of 3 Posts
Top