Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My car needs a jump after setting for 1 hour, there is 14.2 volts when it is running. Battery is good. HELP
 

·
Registered
'87 SDV
Joined
·
1,296 Posts
No normal accessory or light could drain a battery that fast. Sounds like a bad connection. Remove, thoroughly clean and reattach the cables at the battery first. If that doesn't do it, check the ground cable and starter connections.
 

·
Registered
07 Black Raven CTS, 07 Gold Mist CTS
Joined
·
453 Posts
Denver, Noahsdad is entirely correct. I have gone through two Delco's. The positive terminal has leaked on both and I have cleaned the terminal before reattaching it securely. I went to another battery source and have had no trouble since on my 98 Eldorado. The OBDII system also throws some interesting codes during this process that are connected to the electrical system. Most do not return after clearing them after securing the battery and connections.
 

·
Registered
99STS,2004 Jeep Liberty Renegade,98 Deville RIP
Joined
·
1,054 Posts
Denver does the vehicle click when you engage the starter? Does your Fuel mileage reset? After you check your connections, both positive and Negative, (checking the starter connections will get interesting), try as was suggested another battery or your starter is overdrawing. Being a 98 it would be due for a starter. Without knowing what the car does when the key is turned, I would hope it just is a bad connection.
 

·
Registered
Joined
·
927 Posts
If it's not the connections at the battery then it's the battery itself trust me try a different battery and check it out.

Make sure the connections are tight I have seen the bolts strip and they wont tighten properly.
 
1 - 6 of 6 Posts
Top