Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
The blower motor in my 97STS stopped working. There is 12v at the red wire on the connector when grounded to chassis or red and black connected. 0v from blk or white to either chassis or together. from what i've been reading the control module is in the fan motor, but there is a power module elsewhere? Where?

I tried a new fan motor. it still doesn't work...
 

·
Registered
Joined
·
333 Posts
Yes the HIVAC computer is behind the back. right side of the glove box. I have only had to change one but many blower motors
 

·
Registered
Joined
·
19 Posts
I have a 1996 DeVille with a cooked circuit board in the blower motor unit. My question is: Do need to trouble shoot the circuit or is this type of failure typical of the blower motor unit itself?

Also, if these units go out at such a frequent rate, is there a better replacement (ie better designed so it won't go out again....) part available and if so through whom can it be purchased?

I pulled the old unit out by deforming the impeller on the motor itself. Will this cause damage to the new unit? I did not remove anything else during the removal process. Are there any tricks to installing the new unit? I do not want to remove the valve cover etc.
 

·
Registered
Joined
·
7 Posts
the easiest way is doing it on a hoist.
you disconnect the steering coupler at the steering gear , then lower the
rear cradle bolts , and voila. lots of room to access blower!!
 
1 - 4 of 4 Posts
Top