Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My car was running great. drove to work when I tried to start to go home, it started but shut off in a few seconds. The driver information center said anti theft came up and may not start. It would start but shut off right away. After getting it towed home, I tried starting it again. Same problem. After connecting my scan tool, it says it can't connect. I read that the PCM OR EMC might be the problem with many things going wrong. Like traction control, abs, cruise control. Before this all happened I had service emission system. I had time to work on the car. I replaced intake gaskets and many other things like purge solenoid, charcoal canister, well eventually it was the a clogged catalytic converter replaced it, like I said since then the car ran great. Now it starts then shuts off the transmission shift lights all flash at the same time.
Does anyone ever have this kind of a problem?
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,315 Posts
Are you able to pull the DTC's via the onboard diagnostics? Might be a clue there.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I cannot pull anything information from my DTC. Nothing seems to work from rhe DTC or form my scan tool.
 

·
Registered
70 Deville 78 Seville 92 Deville 03 Deville
Joined
·
682 Posts
It sure sounds like a PCM failure. I would probably play with the battery connections and grounds first to make sure that all looks good. Then unplug the PCM a couple times to see if anything changes. If nothing changes I guess I would try another PCM.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,315 Posts
Long shot, but you might also try pulling both battery cables and touch them together in a sort of reboot.
 
1 - 5 of 5 Posts
Top