Cadillac Owners Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
1995 Cadillac Fleetwood Brougham
Joined
·
7 Posts
Discussion Starter · #1 ·
Ok, I have read hours and hours of these discussions and tried a lot. My 1995 Fleetwood wipers work fine, speed up and slow down like they are supposed to do. The issues I’m having is once the wipers come on the only way to get them off is to turn the car off and open the door. The cruise control is also not working. I’m thinking it might be the turn signal, wiper, cruise control lever itself. There is one on a parts car in my town but it looked like I had to take the entire steering column apart to get the lever out. Any help won’t be turned away and make a way to get mine off and a new one on without taking the entire column apart would be nice.
Thanks
 

·
Registered
92 Fleetwood 2dr cpe - FWD, 96 Seville SLS, 02 Seville
Joined
·
1,155 Posts
Probably a sticky relay. Try pulling it out before you turn off the car.
-If still on, then wire short.
- if off, then relay or stalk. Need to back probe the mount for the relay to see if the stalk is still sending a control signal to the relay.
 

·
Registered
1995 Cadillac Fleetwood Brougham
Joined
·
7 Posts
Discussion Starter · #3 ·
Probably a sticky relay. Try pulling it out before you turn off the car.
-If still on, then wire short.
- if off, then relay or stalk. Need to back probe the mount for the relay to see if the stalk is still sending a control signal to the relay.
So I pulled the relay the wipers didn’t come on. Put the relay and they came right on but again wouldn’t shut off. I’m pulling the multimeter out now. I’ll update once I finished chasing this some more.
 

·
Registered
1995 Cadillac Fleetwood Brougham
Joined
·
7 Posts
Discussion Starter · #5 ·
Ok so I know you shouldn’t throw parts at a problem. But I kinda did cause it’s been bothering me. Replaced the relay cause it would turn off when I pulled the relay. Didn’t fix it. Replaced the turn signal, wiper switch. Didn’t fix it. I’m kinda lost until the manuals show up.
 
1 - 5 of 5 Posts
Top