Cadillac Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
My 1994 Cadillac Fleetwood Brougham ran fine , found it leaking slowly out of my water pump. So ordered a water pump ,Optispark, and a harmonic balancer . replaced all the parts and it wouldn't start. I left it alone came back my son had started it , and drove it about 30 feet so we could flush out the radiator, via heater hose line. We did have a small leak around the thermostat hosing ,because I removed it for my first flushing, drained the water added radiator flush and was started with flush you buy , was going to put a few miles on it flush it again . Then wash it out , fill with antifreeze. PROBLEM : car just shut off and want start, its more than likely the spark , or the new cheap Optispark any help here? May have gotten a small amount of water on it, but not a lot. A little water shouldn't affect it , because a big puddle could do worse.Any tips maybe try to see if I'm getting fire?
 

·
Super Moderator 2011 CTS SportWagon
Joined
·
9,464 Posts
Re: Optispark replaced , and want start

Cheap optis are a known bad spot. Take it off, put the old one back on. Do a cap and rotor if you want, or, just open it and clean it. Likely zero coolant in it, it's a sealed unit. My water pump leaked on my opti for two years before the pump bearing blew all the bearings out the back. Had to change it then, lol. Opti still works fine, 15 years later.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Re: Optispark replaced , and want start

Well tested it and has no spark, I did notice the 4 wire connector was severely twisted going to the ignition control module by the coil .With the two inner wires showing . Will check continuity to see if they are touching inside . Yes ran fine, bought a cheap $50.00 one off eBay, because doing the water pump and opened a can of worms . Probably got a bad one.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Well here's the verdict . I removed the new China made Optispark , and noticed the plastic cover/plate under the rotor button had a small crack in it allowing a spark to shot thru it. It had a grayish/black residue on that crack. . So gentleman , I put to new O-rings on the shaft and got a new cap and rotor button and listened to Joe. Thanks my friends on here.
 

·
Registered
Joined
·
4 Posts
Only ACDelco Optispark units have the superior Mitsubishi module. If I were going through all the trouble of replacing an Optispark, I would not be "penny wise and dollar foolish".
 
1 - 7 of 7 Posts
Top