Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1994 eldorado 4.9 L and I'm lacking power when i try and accelerate. It almost feels like im running on 4 cylinders instead of 8 and its been shifting at high rpms. It happened really abruptly just all of a sudden it started doing this. Ive replaced the coil packs, removed my catalytic converter, replaced the O2 sensors, my fuel filter, trouble shooted my spark plugs and there all good, and nothing seems to be fixing the problem, any ideas on what might be wrong with it and how i should go about fixing it?
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
Have you pulled the codes yet? If you don't know how, read the "sticky" thread on how to pull DTCs at the top of the Eldorado/Seville page. Make sure to include code DEFINITIONS.

If your car is a '94, it has a Northstar, not a 4.9.
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,737 Posts
Have the fuel pressure tested. If its below spec, it needs a new fuel pump!
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,273 Posts
I have a 1994 eldorado 4.9 L and I'm lacking power when i try and accelerate. It almost feels like im running on 4 cylinders instead of 8 and its been shifting at high rpms. It happened really abruptly just all of a sudden it started doing this. Ive replaced the coil packs, removed my catalytic converter, replaced the O2 sensors, my fuel filter, trouble shooted my spark plugs and there all good, and nothing seems to be fixing the problem, any ideas on what might be wrong with it and how i should go about fixing it?
===================
I have a 1994 eldorado 4.9 L
can't be - 93 base Eldo was the last year for the 4.9 -

check ALL the fuses -

check for codes -
 
1 - 4 of 4 Posts
Top