Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
Cadillac
Joined
·
103 Posts
Discussion Starter #1
cannot get ac compressor to go what can possibly cause this its a new compressor
 

·
Registered
94 Eldorado, and a 99 ETC
Joined
·
3,887 Posts
Low refrigerant pressure. There is a switch on the low side of the system that will simply disable the compressor if there isn't enough refrigerant. Plus it does it with no codes. Add a can of refrigerant and it should be operational again.
 

·
Registered
1997 SLS
Joined
·
550 Posts
Do you have any ACM codes? If so, reset them and you have about a minute of run time on the compressor to add more refrigerant, if that's what is needed.
 

·
Registered
2011 Crown Vic LX, 2009 Chevy Malibu 2LT
Joined
·
5,607 Posts
If you need to get the compressor to run for the system to take refrigerant, unplug the pressure switch Krashed previously mentioned and jump it with a paper clip. The compressor will run so you can fill with freon.
 

·
Super Moderator
2010 DTS
Joined
·
87,552 Posts
No, clear the codes to enable the compressor, but have everything hooked up and ready to go so it does not reset the code and trip off again.
 

·
Registered
eldorado
Joined
·
125 Posts
You need to clear the codes in the a/c and heater controles to get it to work , you can jump all the plugs you want it wont come on without clearing the codes, someone on here has to have the presedure .. i'll try and hunt it down and post it?
Ranger has to know...
 

·
Registered
99 DeVille D'elagance
Joined
·
1 Posts
gentlemen I seem to be having the same problem ? I am new to your site and trying to find my way around. where is the "sticky post section ?" I need ac compressor to run to suck refrigerant into system.

thanx for any help you might offer

I have a SWEET 99 DeVille D'elegance that needs some TLC
 
1 - 12 of 12 Posts
Top