Cadillac Owners Forum banner

61 - 78 of 78 Posts

·
Registered
Cadillac
Joined
·
17 Posts
Can anyone help with a 1993 Sedan Deville. The car has 90K miles on it and has been very well maintained. However, we are getting a code 38. MAT sensor is low. I changed the MAT sensor and plug but the code remains. Does anyone have any suggetions on this? Thanks.
 

·
Registered
1994 Cadillac Sedan Deville
Joined
·
6 Posts
Hello There,
I own a 1994 Cadillac Sedan Deville and I have a problem with it.
I just google'd '1994 Cadillac Sedan Deville Problems' and your very informative post about them came up.
I noticed that the last post on it was 1995 though, so I was messaging you to see if you still exist :)
 

·
Registered
1994 Cadillac Sedan Deville
Joined
·
6 Posts
Problem, please help
I own a 1994 Cadillac Sedan Deville with a 4.9 motor
Shortly after I purchased the vehicle used I noticed a small knock/tap in the motor during minimum acceleration, but the knock/tap would vanish as the acceleration continued until I would come to a stop and start back when I would accelerate again until I picked speed up once again.
Well, a friend of mine suggested that I use some Lucas Oil Treatment.
I did so, and the knock/tap seemed to disapear.

Now since it is cold outdoors when I first start my Cadillac in the morning I am am hearing a terrible knock I assume from the motor. I am far from a mechanic.

I took this Cadillac to the Chevrolet dealer here in town and had the service manager listen to the small tap/knock before I put the Lucas Oil Treatment in it and his opinion was that the cam was making the noise and that it would only get worse with time.

Please give me some valuable information on this problem?
I have always wanted to own a good Cadillac, and I don't want to get rid of this car if it is not a serious problem
 

·
Registered
93 Sedan Deville 4.9L
Joined
·
1,005 Posts
First off welcome to the forums. but you may have better luck starting a new thread in the 4.9 sub-forum, But the consensus you will probably get is that lucas treatment and other "additives" really dont solve many problems, they can cover them up a bit but dont last.

Few things I would look at, If they dont solve it start a new thread and you will probably get more help from everyone else.

Do you have any codes? Press off+warmer and see if any show up, their is a sticky thread in the 4.9 forum with more details.
Knock on acceleration can often be caused by egr and timing settings. If you aren't already try running a higher octance fuel and see if it improves.

I would also hit the basics like making sure your not low on oil or antifreeze.
 

·
Registered
01 frontier , 89 Shelby CSX vnt
Joined
·
14,607 Posts
Discussion Starter #66
Knocks in the 4.9 are normally becuse of the undersize stock #1 main bearing.

2 things you can do

1 switch over to mobil 1 DELVAC 15w40 diesel truck oil. This works pretty well but wont get rid of the knock completly, normally this is recomended for the 4100 engines becuse of the distributor gear. But it works well for all the pushrod 4.x liter engines. Mine had nothing but devlac 15w40 since i got it in 2003 till the last oil change. No job so i put in chevron , i regret it but moneys tight. now i have oil leaks again....

the other thing you can do once your 100% sure it is the main bearing is to replace them. took me a week on the garage floor to change out all 5 , 4 of them replaced with stock and the number 1 replaced with the upsized GM service unit.

I would go with the oil first , esp if the lucas helped. Be sure to use a GM filter also.
 

·
Registered
1994 Cadillac Sedan Deville
Joined
·
6 Posts
Thank you very much Stoney
I will try that oil and the GM filter
How wil I know 100% weather it is the bearing though?

Does this motor have known cam issues?
 

·
Registered
01 frontier , 89 Shelby CSX vnt
Joined
·
14,607 Posts
Discussion Starter #68
Thank you very much Stoney
I will try that oil and the GM filter
How wil I know 100% weather it is the bearing though?

Does this motor have known cam issues?
ive never heard of cam issues , ive got some lifter noise in the front bank , one never really pumped back up after the main bearing job. but cam bearings and such ive never heard of issues with.
if it knocks under a light load and is hot , say driving in a parkinglot after being on the highway its most likely the mains...and really it will run like that a long time ...mine did it forever , it trashed mains (#1 chunked, 2-4 scored badly, 5 chunked) but otherwise survived ok ...
 

·
Registered
1994 Cadillac Sedan Deville
Joined
·
6 Posts
I am nowhere near a mechanic, but before I put this Lucas oil treatment in the car it sounded like a lifter maybe.
It would be a faint tap, some people might not hear it.
It would happen between the speeds of 5-15mph then it would fade away, I noticed that it would get worse on big hills or inclines though.
So far, the Lucas has gotten rid of that noise, but what concerns me is that it is a real problem that is just being disquised for now.

I wish I knew for sure what this awful noise was when I first start the car up in the morning. I noticed it is worse when it is very cold outdoors and especially when I have not started the car in a couple of days.

I considered taking it to the Cadillac service center in a neighboring city, but I was afraid they would just find any and everything wrong with it just to make some $$$ you know
 

·
Registered
1994 Deville Concours
Joined
·
1 Posts
I need some help here. I believe the instrument cluster panel has shorted out on our 94 Deville Concours. I think I've found a place to repair it but I don't know how to get the panel out. Can anybody help here? I have some mechanical skills. Has anybody else experienced this problem. The Deville just hit 100k a month ago...what a great car. I would appreciate any help.
 

·
Registered
1994 Cadillac Deville
Joined
·
1 Posts
Hey Stoneage, my 1994 Deville with 95,000 has a creaking sound coming from the rear end. It actually sounds like bouncing bedsprings! I think it may have something to do with the ride control. Any Ideas? Thanks!
 

·
Registered
1994 Sedan DeVille 4.9L FWD
Joined
·
1 Posts
Hello, this has been a very helpful site and post thread. I hope I am posting properly, since I don't do this often. My '94 Sedan DeVille front reclining seatbacks have stopped returning to their original positions when pulling the lever. We have determined that the Bloc-O-Lift gas springs have lost their pressure. I have found them from easylift.com's online store, but it is $360 to replace 4 of them which is way too expensive. Does anyone know where to get an after market part or what not that is more reasonably priced? Thanks in advance.
 

·
Super Moderator
2018 GMC Sierra, 1995 Jeep Wrangler
Joined
·
12,114 Posts
Hello, this has been a very helpful site and post thread. I hope I am posting properly, since I don't do this often. My '94 Sedan DeVille front reclining seatbacks have stopped returning to their original positions when pulling the lever. We have determined that the Bloc-O-Lift gas springs have lost their pressure. I have found them from easylift.com's online store, but it is $360 to replace 4 of them which is way too expensive. Does anyone know where to get an after market part or what not that is more reasonably priced? Thanks in advance.
http://www.cadillacforums.com/forums/cadillac-deville-1985-2005-including-1985/

You may also try the DeVille forum for your search. :)
 

·
Registered
94 Deville LE
Joined
·
1 Posts
I have a 94 Sedan Deville, i see you know how to fix the door lock but what about the windows? My left front window rolls down fine and rolls up fine but when it gets closer to the top it just starts to slow down and takes longer than all the other windows. I also have a message "service ride control" I plan on googling that, but if anyone can help its more than appreciated.
 

·
Registered
1994 diville concours, 1987 allante, 1957 series 60 custom
Joined
·
1 Posts
hello fellow caddy affionados, first timer, hope this works. i just bought a 94 deville concourse. it's been sitting for two years outside, and i guess it leaked a little oil (probably from the rear rocker gasket) onto what lookes like the top valley area, and probably down the rear of the block. on first fire-up, as the motor warmed up, smoke from the oil started burning off, but smoke started to fill the passenger compartment. is this possibly the smoke from the engine compartment leaking inside, or should i start looking aroud for more problems? it smelled the same. thanks everyone..............shawn p.s. is post quick reply the right button to press?
 

·
Banned
NONE
Joined
·
5 Posts
Nice job dude,
you really provide a useful and quite interesting information about 1994 Cadillac Sedan DeVille.
i am glad to read about its safety
thanks
 

·
Registered
1989 Coupe DeVille
Joined
·
1 Posts
Nice car. I never drove a monster like this before. Mobster looking car too - 1989 gold coupe with black canvas top. Totally different than my 2005 Acura TL and 2001 BMW 325 CI...:D

The AC was recharged - car has been sitting for 2 yrs. Immediately after the 25 amps fuse burned out - changed it - behaved for 3 weeks. Now, every time I turn on heat or AC - it works for 1 min - than the fuse blows IDEAS ?
 
61 - 78 of 78 Posts
Top