Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
2007 Cadillac Escalade
Joined
·
37 Posts
Discussion Starter #1
I just installed a aftermarket HU (pioneer) in my 1994 eldorado with the proper BOSE amp bypass harness. Everything works great and sounds great except when I change the radio station, the speakers make a loud pop noise and then the radio station comes in. Can anybody tell me what causes this and how I can fix this. Thanks
 

·
Registered
2007 Cadillac Escalade
Joined
·
37 Posts
Discussion Starter #3
thanks CadillacSTS2003, i installed two (2) ground loop isolators into the RCA jacks that run to the speakers and it took care of the pop noise. everything sounds great and better than the factory HU.
 

·
Registered
1994 Eldorado TC
Joined
·
2 Posts
thanks CadillacSTS2003, i installed two (2) ground loop isolators into the RCA jacks that run to the speakers and it took care of the pop noise. everything sounds great and better than the factory HU.
Hi!
I have exactly the same problem!
What is a ground loop insulator and how are they installed?
I use all four RCA line ouputs, do I only need 2?


Hans Isaksen

Norway
 

·
Registered
1994 Eldorado TC
Joined
·
2 Posts
Yes, I do. I really like the sound of them. Not too loud, but very tight and well balanced. I have to repair two units, but that's another story/thread....
The amps mounted in the speaker enclosures, one at each speaker. I have a feeling Heizmann(and others) mixes up the "tuner" box with an amp.
I did not use any bypass harness, I just wired the line outputs from my Pioneer HU to the respective line feeds out of the "tuner"(CDU?) box located by the antenna in the rh. trunk.....
I probably need to check overall grounding, or install two of those ground loop insulators...

Hans
Norway
94 Eldo TC
 

·
Registered
STS'97
Joined
·
49 Posts
I just installed a aftermarket HU (pioneer) in my 1994 eldorado with the proper BOSE amp bypass harness. Everything works great and sounds great except when I change the radio station, the speakers make a loud pop noise and then the radio station comes in. Can anybody tell me what causes this and how I can fix this. Thanks
I have a very similar problem, but with the stock Bose AMP. All of the sudden, the right channel (door speaker) starts poping and crackling like there is some kind of short. it comes and goes. The real puzzler is that it will do this even when the IGN is OFF and the car is simply setting in the garage. I have '97 STS and this just started showing up a few months ago. Please advise??
 
1 - 8 of 8 Posts
Top