Cadillac Owners Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
E16 Voltage Out of Range [ALL SOL] (Generator voltage may be off)
E27 Open throttle signal switch
E31 Shorted MAP Sensor
E52 PCM Memory Reset
E70 Intermittent TPS Signal
E71 Intermittent MAP Signal
E73 Intermittent Coolant Sensor Signal
E98 High RPM P/N to D/R Shift Under ISC

EE 27

It appears that the only current code is 27 (Idle Speed Motor) so I guess Ill test that out. As far as the rest of the codes anyone have any suggestions? My car idles really rough but I drove it from Atlanta to DC last weekend and it ran fine otherwise.

bunyan
 

·
Registered
'91 Fleetwood Coupe, '95 SLS
Joined
·
196 Posts
bunyan said:
E16 Voltage Out of Range [ALL SOL] (Generator voltage may be off)
E27 Open throttle signal switch
E31 Shorted MAP Sensor
E52 PCM Memory Reset
E70 Intermittent TPS Signal
E71 Intermittent MAP Signal
E73 Intermittent Coolant Sensor Signal
E98 High RPM P/N to D/R Shift Under ISC

EE 27

It appears that the only current code is 27 (Idle Speed Motor) so I guess Ill test that out. As far as the rest of the codes anyone have any suggestions? My car idles really rough but I drove it from Atlanta to DC last weekend and it ran fine otherwise.

bunyan
Bunyan: Check the Resistance of your Fuel Injectors! The Rough Idle could be a Dribbling or Partial to Wide Open Injector/Injectors. I believe you should read between 18 to 25 OHMS for a Proper Functioning Injector. I don't have my Shop Manual handy so You Should Check the Archives for the Proper Resistance Numbers. If you are reading from low teens to below 10 OHMS the Injectors need to be replaced. If you have multiple Bad Injectors and the readings for the rest of the injectors are in the low for proper function, Replace All. Idle Speed Motor will not cause rough idle.

Skullman {:{}
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Skullman,
Thanks! Can I just unplug the wiring harness and check them on the car?
bunyan
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Moderators can you move this thread to the HT4100 4.1, 4.5, 4.9 Technical forum? I apologize, but I think this belongs over there :)

bunyan
 

·
Registered
'91 Fleetwood Coupe, '95 SLS
Joined
·
196 Posts
bunyan said:
Skullman,
Thanks! Can I just unplug the wiring harness and check them on the car?
bunyan
~ Yes you can. Did you check the archives for the proper OHM readings? I don't have them at hand. I have done a lot of work to my Fleetwood Coupe and am a Lot More Familiar with things. My Rig has not thrown any codes at all. I also found that my thermostat was open and my Rig would not get to operating temperature especially on the Hiway. The Computer would go into an Open Loop setting making the engine run on basic systems but not optimum controlled by the computer and with that No Codes. This also accounted for the lower than normal Hiway Mileage.

~ The open thermostat, lower operating temperature and open loop would also cause the computer to Not Run the Idle Adjustment Motor. The Bad Injectors were pouring fuel down the cylinders making the Catalytic Converter work overtime. Car always ran Great, a year and a half ago all injectors read within limits............Things Change! Now she runs like a Dream!

~ Wouldn't hurt to disconnect battery to reset and see what codes you pull after.

Skullman {:{}
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Skull,
I checked my injectors today and they all read between 16.3 and 17 Ohms.Looks like Ill be needing some new injectors. Whats the cheapest way to go? Are injectors from a 4.6 cheaper?
I also checked the idle speed motor and thats bad too. I also reset my trouble codes and the only one that got thrown now was 27, 71, and 98. I tried checking the MAP sensor but I really dont know how to check it so I might just pickup a new one depending on how cheap they are.
Are there any special tricks to pulling the injectors? On my car (93 Deville) I think I have to move the power steering pump to get the fuel rail off. If that is right does anyone have any tips or tricks in getting that off? I plan on replacing all this stuff as soon as I can order dome cheap injectors from somewhere...
 

·
Registered
1993 Eldo 4.9 66K miles
Joined
·
368 Posts
Injector resistance is in spec. 12 to 20. Clean all battery connections including grounds, clear codes then start over.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Nicky what you say? My Haynes says 11.4-12. something or another, I know it definately was NOT supposed to be 16. Are you sure about your specs? Where did you get them from?

bunyan
 

·
Registered
'91 Fleetwood Coupe, '95 SLS
Joined
·
196 Posts
bunyan said:
Skull,
I checked my injectors today and they all read between 16.3 and 17 Ohms.Looks like Ill be needing some new injectors. Whats the cheapest way to go? Are injectors from a 4.6 cheaper?
I also checked the idle speed motor and thats bad too. I also reset my trouble codes and the only one that got thrown now was 27, 71, and 98. I tried checking the MAP sensor but I really dont know how to check it so I might just pickup a new one depending on how cheap they are.
Are there any special tricks to pulling the injectors? On my car (93 Deville) I think I have to move the power steering pump to get the fuel rail off. If that is right does anyone have any tips or tricks in getting that off? I plan on replacing all this stuff as soon as I can order dome cheap injectors from somewhere...
~ Sorry man, I was away for a while. You are within specs. I don't know why Hanes manuals report those low readings. I can tell you by experience that when the readings get that low you have New injectors in the near future! FYI injectors are Not Cheap! I had a friend order them up back east, $68 bucks a piece for Bosch rebuilds with Life Time Warranty! That's a Deal! Follow NicktSantoros advice and report back. Have you replaced that idle speed motor? I'm back in the Bay Area and have access to my Factory Manual.

Skullman {:{}
 

·
Registered
1993 Eldo 4.9 66K miles
Joined
·
368 Posts
bunyan said:
Nicky what you say? My Haynes says 11.4-12. something or another, I know it definately was NOT supposed to be 16. Are you sure about your specs? Where did you get them from?

bunyan
From the FSM. BTDT on injectors with the 4.9. Do as you see fit however. It's your car, not mine.
NS out...
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
Thats cool, I sold her for a grand anyways. Now im trying to find a 95 Fleetwood Brougham yeah!

bunyan
 
1 - 11 of 11 Posts
Top