Cadillac Owners Forum banner

1 - 9 of 9 Posts

·
2000 Deville base 2019 Corvette Gran Sport
Joined
·
1,001 Posts
Discussion Starter #1
On both my 93's the anti lock idiot light on the dash board is on. On the coupe I just bought it comes on after 10-15 minutes of driving and goes out when you restart the car. I know you can't pull brake codes from the dash on these cars and I ain't paying to have them pulled. What usually causes this as this must be a common problem on these cars.
 

·
Registered
2005 Lexus LS430, 1993 Deville
Joined
·
181 Posts
The first thing that comes to mind with this is maybe a wheel hub sensor sending bad information to the BCM. I haven't
heard of this being an issue with these cars though. You could pull the tires off and take a look at the connectors
and the wheel hubs. The only real way to tell is with the codes.
 

·
Super Moderator
White Diamond '03 DHS (with DTS floor shift)
Joined
·
86,783 Posts
:yeah: When the ABS light appeared on my '92 Deville, I just ignored it. Six months later the bearing started to growl so I changed the hub & bearing assembly.The growl went away and so did the ABS light.
 

·
Registered
1991 Cadillac Sedan deVille
Joined
·
591 Posts
Check the connections/cables to the wheel speed sensors. When I bought mine the light was on, and I ignored it just like Ranger. Then one day I decided to check the sensors and their wiring. I found out that the wiring for both front wheel speed sensors had its insulation cut in a couple of places, and looking closer at them I saw the ground sleeves were also cut. I used paper clips to wrap around each end of the broken ground sleeves, then soldered the paper clips to the sleeves, and wrapped some electrical tape around the newly created bridges. I turned the key on and the light disappeared. It's been good for almost four years.
 

·
2000 Deville base 2019 Corvette Gran Sport
Joined
·
1,001 Posts
Discussion Starter #5
:yeah: When the ABS light appeared on my '92 Deville, I just ignored it. Six months later the bearing started to growl so I changed the hub & bearing assembly.The growl went away and so did the ABS light.
I actually have two brand new hub assembly's that I was going to use in my sedan but being that I am taking that car off the road and going to use the coupe I just purchased exclusively, I will put them in the coupe along with new pads and rotors ( i was going to do this anyway ) and see what happens.
 

·
Registered
1991 Cadillac Sedan deVille
Joined
·
591 Posts
Ok, were the '92 and '93 fitted with hub & bearing assemblies that had the speed sensors on them? My '91 doesn't have the wheel speed sensors on the wheel hub & bearing assembly.
 

·
Registered
95 Deville
Joined
·
7 Posts
I do not know how different 93 is from 95. On my 95 I can trigger the codes by holding the Climate Control's Off button and Hot/Red Button for about 5 seconds. Codes T 021-037 are Wheel Speed Sensor related. My 95 does the same thing with the ABS light and the gives me the Traction Control Disabled message. Says it's the Passenger Front.
 
1 - 9 of 9 Posts
Top