Cadillac Owners Forum banner

1 - 12 of 12 Posts

·
Registered
1992 Fleetwood Cadillac
Joined
·
7 Posts
Discussion Starter #1
Here recently my car has been completely dieing or stalling out, both service engine and service vehicle lights show up. When it doesnt die out I can still drive it just feels like the car is barely draging along.

Sometimes it doesnt happen all day then others it does.

My question is how to solve this problem? Maybe bad ground, maybe one is going out.

Where are the ECM/BCM Located. How do I go about replacing them or testing them or cleaning them?

Any help would be greatly appreciated. I just got finished doing so much work on this car and now this :/
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,278 Posts
Here recently my car has been completely dieing or stalling out, both service engine and service vehicle lights show up. When it doesnt die out I can still drive it just feels like the car is barely draging along.

Sometimes it doesnt happen all day then others it does.

My question is how to solve this problem? Maybe bad ground, maybe one is going out.

Where are the ECM/BCM Located. How do I go about replacing them or testing them or cleaning them?

Any help would be greatly appreciated. I just got finished doing so much work on this car and now this :/
=================================
My question is how to solve this problem?
DIAGNOSE the problem - then fix it -

simply throwing parts at it -
and HOPING something "sticks"
is the worst approach - and the most expensive -

start by checking for codes -

if you have any codes -
post the code numbers - ALONG WITH THEIR DEFINITIONS -
 

·
Registered
1992 Fleetwood Cadillac
Joined
·
7 Posts
Discussion Starter #3
Sorry about that I guess i been doing it wrong then I buy the parts throw it on if it doesnt work i have a new part. Im eventually gonna restore the entire car, I hope.

Codes are
F32 ECM-BCM
F47 Low refrigerant
E70 TPS Signal
E22 Open TPS Circuit
E52 ECM Memory Reset

I figured yhe most important one to tackle would be the Code 32. Then again I could be wrong. Thanks for any help.
 

·
Registered
1992 Fleetwood Cadillac
Joined
·
7 Posts
Discussion Starter #4
One more thing to mention is I changed the TPS module on the car so that may be an old code sticking. It is not showing up anymore. Now just Codes F32, F47
 

·
Registered
1992 Fleetwood Cadillac
Joined
·
7 Posts
Discussion Starter #5
Today I found what looked to be my Ecm or Pcm above my fuse box on drivers side behind stearing wheel. I dissconnected it and made sure all wires were looking good and cables were snapped in place i reset my diagnosis.

Drove the car around for about 6 hours and didnt have a single problem. I wonder if the cables were just loose or what. Im not sure what I did had amy effect but for the moment its running normal. Hope it was just a loose cable pin or somthing and i seated it correctly. Still any help would be greatly appreciated!
 

·
Master of the Dark Art of Diagnostics
2003 DHS - two-2002 DHS, 2003 SLS, 1995 Sedan DeVille, 1989 Coupe DeVille
Joined
·
19,278 Posts
Today I found what looked to be my Ecm or Pcm above my fuse box on drivers side behind stearing wheel. I dissconnected it and made sure all wires were looking good and cables were snapped in place i reset my diagnosis.

Drove the car around for about 6 hours and didnt have a single problem. I wonder if the cables were just loose or what. Im not sure what I did had amy effect but for the moment its running normal. Hope it was just a loose cable pin or somthing and i seated it correctly. Still any help would be greatly appreciated!
======================
your car is 23 years old -
it's possible the terminal pins were dirty/corroded -
and the act of unplugging - and plugging the connector -
has cleaned the connectors -

you might consider doing it again -
but use a good electrical contact cleaner -
 

·
Registered
1992 Fleetwood Cadillac
Joined
·
7 Posts
Discussion Starter #8
Ok so today I drove it around all day and had no problems at all. Tonight I took it home and sprayed it down real good and washed it. Got my girls out and was gonna go for a late night cruise. They love to ride on daddys cadillac. Well... Soon as I pulled put the driveway BAM Check engine and car dies. Pull codes F32.

I pull back in the deiveway and start messing with it, checked battery terminals, checked the fuse box and whatever that computer looking thing under my stearing wheel is and got it started back up.
We went and drove around for about 30 minutes, I pull in the local Pantry to get some dranks and leave the car running. Come back out about (5 mins inside store)
Check engine code F32 is up again. I barely make it back home and its sitting in the driveway still screwed up with code F32.

I dont know what is cause this it just seems so random. Washing my car maybe got something wet? Maybe idleing and some wire got to hot? Anyways any help is appreciated.
 

·
Registered
Joined
·
176 Posts
If it misses really bad and backfires, it's likely that you got the distributor wet... dry it out with compressed air and let us know if that worked.
 

·
Registered
1985 Sedan DeVille
Joined
·
1,883 Posts
pretty sure your ECM is toast and the car is running in stupid mode because nothing is controlling spark and fuel, but I would try to isolate it more. take a good whiff of the ECM and the BCM, if either of them smell like burnt electronics that's the problem. do you get any other codes? does the fuel computer blank out (suggests BCM)? next time it happens put the climate control into diagnostic mode and see if the SERVICE NOW and SERVICE SOON both light up, if not then the ECM is dead
 

·
Registered
1992 Fleetwood Cadillac
Joined
·
7 Posts
Discussion Starter #11
The service engine and service engine Soon both pop up. I run diagnosis and it shows F32. If i turn my car off for a few seconds and start it back up it usually fixes the problem. Somtimes i got a memory reset code or a TPS signal loss code. Its weird.
 

·
Registered
1992 Fleetwood Cadillac
Joined
·
7 Posts
Discussion Starter #12
I replaced my TPS and Tp Motor also restored my throttle body and riser. Seems to be idling perfectly now. Still throwing code F32. Gonna do some more research and fogure out which wire is bad and causing it to throw this code
 
1 - 12 of 12 Posts
Top