Cadillac Owners Forum banner

1 - 14 of 14 Posts

·
Registered
Currently a 1992 Allante,
Joined
·
1 Posts
Discussion Starter #1
I have a few questions about the 1992 Allante. My brakes make and electric noise under the hood when applied, Front radio speakers don't work, rear top pull down occasionally closes and then releases the top. Cruise control doesn't work. Is there a lamp on the dash to indicate cruise engaged? Sorry for all the comments and questions, but I know the car is delicate, and I am a newbie!
thanks for all considerations!
 

·
Registered
Triple Yellow 88 Biarritz, 92 Allante, 05 STS
Joined
·
103 Posts
Welcome! I have a 92 that I am going thru also. If your brakes work fine, it might just be the pump working as it normally should, others may be able to provide more insight than me. If you haven't flushed the brake fluid yet, you may want to as many allante owners do annually or semi-annually on theirs. Front speakers are bose and are notorious for bad capacitors on the amp inside the speaker box. If you have solder skills you can replace them yourself, or find someone local too, car stereo help repaired 2 of mine for $80 a piece. my top does this too, it needs adjustment, haven't done that yet. yes there is a cruise light that comes on in dash, you will have to diagnose a little further, fuse? vac lines to cruise servo?
 

·
Registered
'92 ALLANTE & 02 EXT
Joined
·
114 Posts
You can get the amps out of 90s Eldorados. They are rated at 100w but work fine. Just make sure you have the matching harness cause the Eldo is different. I have a '92 and replaced all 4 . Pull - A -Part is your best bet.

----------

The Eldorados are attached to 6x9s on the rear deck but are removable from the 6x9. You can probably get amps & speakers for about $10.00 a piece.
 

·
Registered
1955 CDV, 1992 Allante, 1962 Olds 88 Conv
Joined
·
201 Posts
The brake system should NOT "make an electric noise" each/every time they are applied.

Is there a brake warning light on the dash?

Do you know how to/have you pulled the codes from the DIC?

You may want to travel over to AllanteNet to get help from fellow owners -
 

·
Registered
1993 allante 91 allante
Joined
·
110 Posts
The brake system should NOT "make an electric noise" each/every time they are applied.

Is there a brake warning light on the dash?

Do you know how to/have you pulled the codes from the DIC?

You may want to travel over to AllanteNet to get help from fellow owners -
Dave is correct the pump should not run every time you depress the brakes.You may find more help at John Monzo's site.He has just updated the chat section of the site and you can post questions and review answers at any time here is a link to the homepage you do not have to be a member to join us in the chat room. http://cac.clubexpress.com/content.aspx?page_id=0&club_id=434240
 

·
Registered
1993 Allante
Joined
·
7 Posts
Had a similar issue recently with the rear latch on my 93. Check the plastic limit switch on the pull down motor. Mine wasn't making enough contact to shut of at the bottom . I lightly bent the plastic contact up so that it shut off when it reached the limit. Hope this helps.
 

·
Registered
1991 Cadillac
Joined
·
58 Posts
Hey- -

Verify that the brake light is functional in the dash. This brake light should illuminate when you set the parking brake and or when you turn the ignition switch to the run position (engine not running) If you have brake issues and the light has failed, you would never know. The electric noise, most likely, as stated here, is the ABS pump running. If it runs each time the brakes are applied, then most likely you will need a new accumulator. Dick Hussey in West Palm Beach is an excellent source for these. Google him. He is at Allantesource.com

Hope this helps

Bill
 

·
Registered
Triple Yellow 88 Biarritz, 92 Allante, 05 STS
Joined
·
103 Posts
Tn Kjun, what years of Eldorado's did you get the amps from? 92-95 or 96-02 or are they all the same?
 

·
Registered
'92 ALLANTE & 02 EXT
Joined
·
114 Posts
I got some out of 97s & 98s but I think they are all the same. They are rated @100w but it makes no difference. If you're gonna put them in an Allante be sure to get the speaker & amp harness cause some are a lil different & the wire color code is different. Some Allantes are hard wired at the amp & some are plugged in at the amp.
Hope this helps

----------

Some are also attached to the back of 6 x 9 but they work too &are removable.

----------

I'm running 8 speakers & amps in my '92 and it sounds great. I added 2 6x9s in the rear fold down door & 2 6x9s in the front at the bottom of the seats.
In case you're wondering.
 

·
Registered
'92 Allante, '93 Allante
Joined
·
76 Posts
You state, "rear top pull down occasionally closes and then releases the top." If you mean that the J hook releases as the top is being pulled down, I would suggest that you check that the release cable, where it attaches to the pull down motor, has sufficient slack in it. I have found that if there is not enough slack, as the motor rotates down, it will tighten the cable and release the J hook. As for the cruise control, there is a lamp that lights signaling the cruise is engaged, in the center of the speedometer.
 

·
Registered
allante
Joined
·
58 Posts
Tn Kjun when you hooked up the extra speaker's did you just splice the wire's from the left & right speaker's to the extra one's also to other's looking for speaker & amp's you can get them from 1995 to 1999 Nissan maxima or ultima model's with a bose the amp's matched I picked up 4 at the local pull your own for $13.00 a pair then looked on speaker wiring on googol for both to match note my allante is an 89
 

·
Registered
Triple Yellow 88 Biarritz, 92 Allante, 05 STS
Joined
·
103 Posts
Thanks, I will search the local yards. I got my last fall with one speaker working. Got 3 working, had the 4th working, but the sound quality was not perfect, so I was running 3 speakers (2 fronts & 1 rear), but the rebuilt 3rd rear I think just went bad, so I just have 2 fronts. I think I might try newer junkyard amps before I spend $$$ again on used/rebuilt/etc. without success.


Are the connector from the Eldorado or nissans the same as the allante, i.e. plug n' play without wiring splicing? Mine allante amps are not hard wired to speaker amp, plug wire connector from amp to speaker inside the speaker box.
 

·
Registered
'92 ALLANTE & 02 EXT
Joined
·
114 Posts
The 5 wire plug at the amp are the same on the Eldorado. Not certain about the Nissan cause all the amps I got were from Eldos. Some say that the rear amps are different from the front as for output but I don't notice any difference. It is also stated that there is a difference between cloth interior & leather but you would really have to have a very sensitive ear to notice that.
$5.oo at the junk yard versus $100.00 rebuild ?
You be the judge!

----------

The plug from the car to the enclosure is different so you will have to make sure the right wire is plugged into the amp.
Orange heavy wire is 12v.
Black is ground.
Dark blue is speaker +.
Brown is speaker -

----------

Just finished adding 4 amps & speakers from an Eldorado to my Harley Ultra Classic and it sounds great!
 

·
Registered
allante
Joined
·
58 Posts
as per the wiring from the Nissan speaker's they had four wire's two were for twitter's I went to wiring site for the 95/99 Nissan's speaker's this show's wiring for the speaker's ,found which one's were for twitter's taped them off then went (same site) found wiring for the allante and matched the wiring to the allante
 
1 - 14 of 14 Posts
Top