Cadillac Owners Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a 1991 caddy deville that i just baught about a month ago, my problem started a few days ago when i was very low on fuel. the car began running very rough when i filled the tank it smoothed out but then the next day my problem began. if i get in the car cold and take off there is all the power i can get but as soon as the car warms up and i step on the gas it hesitates almost like there is no gas, let off the gas and it is ok, i have tried gas line treatments etc, also if i shut the car off wait a few minutes then start and go it is fine but after a few moments it hesitates again, it is now doing it while in park and stepping on the gas, it chokes like it is getting no gas and sometimes makes slight backfiring noises, let off the gas and slowly accelerate and it is ok." i must add that a few days after purchasing the car i went on a short day trip to pennsylvania and it dogged badly on the hills until i stopped to refuel and added a fuel additive then it was fine after that, i do not know if these two instances are related or not but any help would be greatly appreciated
 

·
Registered
Joined
·
29 Posts
I recently had a similar problem in my 93. I'm not sure exactly what caused it, but after re-setting the timing, changing the oxygen sensor, replacing the fuel filter, and replacing the Idle Air Control Module, mine doesn't do that anymore. One thing that mine was doing at the same time was, when left to idle, it would "race" at about 2k RPM. As it was doing this, both of my exhaust manifolds were turning bright red. The reason for this was a lean misfire. The computer was leaning the A/F mixture way out and it was running poorly as a result. On checking the sensors and connectors and everything, we found that the donut gasket between the down pipe and the right exhaust manifold had deteriorated away to nothing, and the oxygen sensor was pulling a false reading due to the leak. That was part of it. The other part was the IAC module. It was bad, and needed to be replaced. When you shut the car off, the IAC motor should move the throttle butterfly open and closed a couple of times. You can tell if it is doing this by turning the car off, and watching the gas pedal. It should move up and down 2 or 3 times. Hope that helps!
 

·
Registered
1995 Sedan De Ville (4.9 L)
Joined
·
581 Posts
When the gas was low, maybe some debris sitting at the bottom of
the fuel tank went in the fuel line? Did you check the fuel filter?
Hope they didn't get in all the way to the injectors.
 

·
Registered
Joined
·
6 Posts
Me too, anyone else?

twistny, did you find a solution?

I have a 95 4.9 that when pulling away from stops, will not accept any throttle until the car is rolling. When I push the throttle from a stop, the car will stall.

I too have had my car only a week and was fine until it started raining the other day, maybe just coincidence?

Any one else with other suggestions?
 

·
Registered
01 frontier , 89 Shelby CSX vnt
Joined
·
14,607 Posts
Re: Me too, anyone else?

always check fuel/air filters before doing any other kind of work on a EFI car , a clogged fuel filter or airfilter will cause headaches

no real way to check the fuel filter other than looking at it to see if "maybe" its the original one , if i remeber right it should be swapped every 30-45k , cant count how many times ive resoleved fuel problems by changing the fuel filter
 

·
Registered
Joined
·
81 Posts
My LeSabre was acting very similar to that then it quit for awhile. It started doing it again a few weeks later. Turns out the fuel pump was going out. FI is VERY sensitive to fuel pressure. Wouldn't hurt to have a pressure test done on your fuel pump. Naturally mine finally went right after I filled the tank....... :annoyed:
 

·
Registered
Joined
·
176 Posts
If it's ok and then gets bad, and is ok after it sits I'd say it's the fuel filter. Seen that alot. All the junk settles to the bottom, and it flows ok till it all get stirred up and then it clogs, then it settle again when u let it sit. $12 solution. Have fun.

D.
 

·
Registered
Joined
·
6 Posts
It's been a while but I thought I would post an update and ask another question. I have the '95 with 40k miles.

The only time my car had a big problem was in a heavy rain storm, a huge hesitaion/stall pulling away from a stop. It still acts a little funny when it's foggy or chilly (for so. cal) in the morning.

? #1: Is there any component that would be affected by humidity in the air?

I did change the fuel filter, air filter and rotor/cap without any noticable change. Since the weather has been nice, it basically runs pretty good, just a tiny hesitation pulling away from a stop.

The EGR tubes were pretty crust so I gave them a few pokes, but they still need some cleaning. The Throttle body is also pretty gooey.

? #2: If I want to use a spray carb/choke cleaner, should I have the motor running or off? Or what is the best way to get everything nice and clean?

? #3: With the low milage, which components might be prone to failure from lack of use.

Thanks
 

·
Premium Member
Joined
·
9,575 Posts
Old, cracked spark plug wires do not like humidity.... Park the car in a dark place and open the hood while idling. Mist the spark plug wires with water from a spray bottle and watch for arcs and sparks....there shouldn't be any.

Clean the EGR tubes out with a piece of stiff wire. They don't need to be shiny polished clean...but they should be free of carbon and such all the way thru so the EGR can flow. If plugged, they can cause hesitation and poor driveability.

Clean the throttle body bores and the throttle plates with the engine off. You have to hold the throttle blades wide open to clean the bores underneath the blades...which is what is important. Spray the bores and backside of the blades with carb spray and scrub with an old toothbrush. Just don't spray the whole can in there with the engine off....LOL
 

·
Registered
Joined
·
6 Posts
I cleaned up the throttle bodies and it seemed to do the trick. There seems to be a few of us with this issue, give it a try.
 
1 - 11 of 11 Posts
Top