Cadillac Owners Forum banner

1 - 20 of 41 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
hey guys, i got a 1990 fleetwood FWD 4.6L FWD, anyways... i dont know whats wrong but my engine is sputtering while i'm driving, its cutting out.... losing power, and just plain out pis**** me off. it started off only while i was at higher speeds, now its doin it even from take offs and everything else. i gave it a full tuneup and its still doing it... well actually i haven't replaced the spark plug wires... thats my next thing but anyways.... anyone got any ideas?? its got a 122K miles, and is clean. and yeah i run premium gas 91octane, althoughi have used lower grades before. thx.
 

·
...Reloaded
'05 XLR
Joined
·
1,698 Posts
Hey HooDLuM - Welcome to the CadillacForums!

Assuming the plugs you just put in are all OK, the next things I would do are the plug wires as you mentioned and changing the fuel and air filters. If none of these fix the problem you need to look into this more carefully - could be an ignition issue, fueling issue, or even clogged cats...among other things...

Thanks for registering! :welcome: Let us know how it goes...
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
yeah i've replaced the fuel filter and i was having this problem before i even did the tuneup.. i did the tuneup thinking that was the problem but it wasn't. anyways yeah my air filter is clean and i'm scared to find out whats wrong :(. oh yeah and if i'm just idling and rev up its pretty much fine for the most part, it seems to do it mostly with a load ( while i'm driving )
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
yeah alright.. i'll take a look into that and let u know.. thanks
 

·
Banned
1995 ETC, 75 Deville, Cad500 powered 73 Apollo, 94 Mark VIII
Joined
·
7,971 Posts
I'm pretty sure you have the 4.5 rather than 4.6 (4.6 is the displacement of the northstar).
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
oh yeah thats my fault, it is 4.5, i was thinkin about my friends GT mustang.. lol
 

·
Registered
Joined
·
1 Posts
Bump...

I'm having the same problem mentioned above with the same car... Anyone have any Ideas. My Volvo and my BMW are almost dead and I need my Caddy to drive to Cali next month.
 

·
Banned
Cadillac
Joined
·
16,105 Posts
:welcome: I agree with Sandman, however my guess would be to also check for a cracked distributer cap. I had these symptoms with an old Dodge and due to the cracked cap, it was running rough on only 6 cylenders.
 

·
Registered
1993 Sixty Special, 1991 Allante
Joined
·
138 Posts
Ralph said:
:welcome: I agree with Sandman, however my guess would be to also check for a cracked distributer cap. I had these symptoms with an old Dodge and due to the cracked cap, it was running rough on only 6 cylenders.
What about the fuel pump? I had a Cavalier one time which had the same symptoms you speak of and after a mechanic replaced nearly all of the above-mentioned things, it ended up being the FUEL PUMP!!
 

·
Banned
Cadillac
Joined
·
16,105 Posts
dooscoop32 said:
What about the fuel pump? I had a Cavalier one time which had the same symptoms you speak of and after a mechanic replaced nearly all of the above-mentioned things, it ended up being the FUEL PUMP!!
Sounds plausable. My only experience with a bad fuel pump was with another car I had, and the diaphram inside or whatever started to leak. But no sputtering. I imagine that if it is played out, it would cause those symptoms.
 

·
Registered
Joined
·
23 Posts
Ways to check various things:

With the cat, when the car is giving you issues, and doesn't
want to run, climb out and look under. If you cat is clogged,
it will likely be glowing. This isn't 100%, but it's common
enough. Any muffler shop will be able to tell you if you're
cat's bad. Getting this job done at a dealer is a bad idea.
You'll spend 3 times as much. Any muffler shop can do it,
and it's hard to do poorly.

For checking the fuel pump, there is a pressure valve on
the fuel rail. Beg, borrow or steal a fuel pressure gauge
and connect it to the fuel rail. I'm not sure what the rate
should be on this car, but maybe someone else here has
that info.

Your injectors can be checked with a stethescope and
wand, or a screwdriver. With the engine running, touch
the end of the stethescope or screwdriver to the injector,
and listen at the other end. You should hear a healthy
engagement sound. If in doubt about the sound, more than
one or two injectors usually go bad at the same time unless
there is a bigger problem, so just listen to them all. The
minority injectors will be the ones that have gone bad.

Replace those plug wires if you haven't done that. Also,
pull the cap and check the rotor and contacts under the
rotor. If they are burned, or coroded . . . replace them.

Also replace your fuel filter. This can cause fuel flow issues
that will look similar to a bad pump, causing starvation to
the engine under load and off the line. A bad filter can also
clog your injectors.

Once all of this is done, hit your next tank with some injector
cleaner. I find that the Techron cleaner from Chevron works
pretty well.

-Dirk R.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #13
alright well 3 months later and all these parts getting replaced my car is still screwed! i'm getting E 41 on the computer, and E 52. i think the E 52 is coming up because i just replaced my starter and disconnected the battery and all that, "E 52" is memory reset or some crap. and E 41 says that it is a Cam sensor problem or circuit fault. My 1990 fleetwood doesn't have a such thing as a cam sensor so im believin it is a circuit fault now. I was getting a error saying my map sensor was shorted and i replaced that, but my car is still runnin like crap. I got a new catylic converter,EGR valve and EGR cylinoid or whatever... and full tuneup and fuel filter. my car can run and be just fine one minute but the next it can run like total crap and stall. this is confusin me so bad its drivin me nuts! i tested my fuel pressure and im getting about 40 and its steady, i rev it up and its steady.... i was tryin to see what my fuel pressure was when it starts to run like shit and stall but it wasn't happening to me when i wanted it to....... i'm starting to think my whole computer is shorted or somethin... i dont know... this is crazy.
 

·
Registered
1968 Cadillac Sedan deVille, 1994 Chevrolet G20
Joined
·
2,795 Posts
Check your pickup coil. It's under the distributor cap, and could give the symptoms you describe (including the code)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #15 (Edited)
ok i tested my fuel pressure while my car starts sputterin, cuttin out and stallin... and the fuel pressure was just fine... about the coil.. ill check into that right now.. oh yeah my "service engine soon" or whatever it says light is comin on... if that helps.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #16
alright i ran tests on the coil and checked out the OHMS and all this other crap and its all testing out perfect.... i'm starting to lead to the computer. anyone else with any kind of tips or input please let me know!
 

·
Registered
1926 Model T street rod, 2000 Jaguar XJ8, 1999 Corvette.
Joined
·
6,738 Posts
We are talking about the PICKUP COIL on the distributor base , not the ignition coil. . Also no mention if in fact, the plug wires were replaced? advise. The pick up coil can fail after a certain temperature is reached which would account for the intermittant symtoms. Both the plug wires and pickup coil are likely culprits at this mileage.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #18 (Edited)
the plug wires are new and the pickup coil is fine... and the problem also can start when i first start the car up. my exhaust even smells nasty,,,, and its idling rough too.
 

·
Registered
Joined
·
12 Posts
Something similar happened to me on my 89 Fleetwood at high rpms and going up hill. I replaced the fuel filter and it stopped sputtering out at high rpms and going uphill, but I do get the occasional stall and sputter when my fuel is low, ~4 gals. I heard there's another fuel filter inside the gas tank you might want to check that if you haven't.
 
1 - 20 of 41 Posts
Top