Cadillac Owners Forum banner

1 - 8 of 8 Posts

·
Registered
1990 Brougham
Joined
·
1 Posts
Discussion Starter #1
Bought a 43,000 mile 1990 Brougham from original owner, been sitting since 2010. Car will start and run off of starting fluid, removed gas tank. Inside tank was horrible, varnish, rust, pump bad,sending unit bad. replaced gas tank, pump, sending unit, powerrred up new pump off of a car battery, tested, it pumps gas as it should. Installed assembly back in car, I am not getting any power to male chassis plug that connects to female pump assembly plug. checked and tested the 10 amp fuel pump fuse, assumed I checked the correct fuel pump relay with a working horn relay. i am a bit confused on if I am determing the correct relay for fuel pump. Schematic decal on under dash cover shows 2 banks of relays. Left side of decal from top to bottom shows a "y" type symbol, next shows a horn, next is blank, next is rear window de-icer, followed by "PRNDL" with a detent indicator below the "P" ---Right side of decal shows first space is blank, second down resembles maybe an injector?, 3rd down shows a circle around some what of maybe a gas pump?, 4th down is blank, 5th down is "PRNDL" with detents under "P" , and "N". Does anyone know the correct symbols for all the relay decal? The vehicle is also equiped with a GM Goodwrench Vehicle Security System black box under the steering column, all wired up with a toggle switch and another small pull devise missing the pull mechanism. Is there any way to dis-arm or by-pass this system? The Black box has 8944 on back side, dated 5-89. Any help greatly appreciated.
 

·
Registered
1985 Fleetwood 75
Joined
·
345 Posts
Check the relay that has the circle with the gas pump put hand on relay and turn key see if you can feel it click it may click off after about 3 seconds and no start position.
also check in motor for the oil pressure switch it may have the fuel pump circuit into it sensing oil pressure. if no oil pressure fuel pump will stop for safety.
ECM should turn on fuel pump relay then allow oil pressure switch to take over when running. it is possible the ecm is not supplying relay drive to fuel pump relay.
or oil pressure switch is faulty. pull relay and make voltage measurements on coil contacts and power input and output to fuel pump. also output from ECM should supply ground to energize relay coil.
if no ground drive then internal quad drives are defective and ECM repair needed. then check immobilizer cct. does key have a resistor chip is it correct for ecm? is the key contact faulty in sensing resistor.?
 

·
Registered
91 Brougham 5.7
Joined
·
56 Posts
Check the fuses too.

Like I told GB, my dumbass only plugged in on end of the adaoter on the fuel pump.
 
1 - 8 of 8 Posts
Top