Cadillac Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Cadillac
Joined
·
3 Posts
Discussion Starter #1
Hi all,

I just picked up a 1990 Allante this weekend with 39,000 miles on it. The car had been sitting for 2 years. When the car is running it is reeking of fuel, getting about 10mpg and has NO power at all. I had a hard time getting over 70mph. I don't see any fuel leaks but just driving the car with the top down was burning my eyes from the smell of fuel. Does anyone have an idea on what could be causing this?

Oh yeah, the speedo was jumping all over the place too.

Thanks,
Rasky
 

·
Registered
Cadillac
Joined
·
3 Posts
Discussion Starter #2
I also noticed there was a lot of pressure built up in the gas tank. I could even hear a hiss when standing next to the car. When I was getting gas pressure was releasing from the cap for a very long time and you could hear the tank making noise as the pressure was being let out. Know I know gas tanks always have pressure built up in them but this seemed rather excessive...is this normal for the Allante?
 

·
Registered
Joined
·
191 Posts
That kind of pressure buildup is not normal. There is a vent on the tank down under the car near the fuel filter. That could be clogged. You possibly could have a leak somewhere, or a fuel pressure regulator problem?
 

·
Registered
Cadillac
Joined
·
3 Posts
Discussion Starter #4
That kind of pressure buildup is not normal. There is a vent on the tank down under the car near the fuel filter. That could be clogged. You possibly could have a leak somewhere, or a fuel pressure regulator problem?

This car is weird! I drove it last night and it ran much better. No fuel smell and had more power...though not as much as the '87 I drove last week. Then I went to move it again later and the CEL came on and it ran rough. This morning on the way to work it ran fine again. Before I had to hold the drivers window and passengers window switch at the same time to get it to roll up or down and now it works with just one.(seller told me about that one) The speedo has been working properly again now too. I think this thing is an electrical nightmare!
 

·
Banned
Is one enough ?
Joined
·
645 Posts
any car that sits for TWO years is bound to have electrical issues.
if you bought the car not knowing that, may i suggest that you
acquire as much knowledge about correcting electrical issues and
oxidation of connectors as you can?


should you take the attitude that the car is nightmare on week one,
my advice would be to sell it ASAP as such an attitude combined with
neglect by prior owner equals INSANITY. Not a good way to start.

i love these cars and after 5 years of hard daily driving, i dont see it as a
nightmare, never have. A challenge, sure.

after 17 years of age, do expect that some things will need a bit of work.

do a Google for a combo of < GM e-ghosts electric problems > and you should
hit several fixes for the ills of such a car.

lol
 

·
Registered
Cadillac
Joined
·
3 Posts
This car is weird! I drove it last night and it ran much better. No fuel smell and had more power...though not as much as the '87 I drove last week. Then I went to move it again later and the CEL came on and it ran rough. This morning on the way to work it ran fine again. Before I had to hold the drivers window and passengers window switch at the same time to get it to roll up or down and now it works with just one.(seller told me about that one) The speedo has been working properly again now too. I think this thing is an electrical nightmare!
I'm having simular issues on my 88 Allante. What was your solution?
 
1 - 6 of 6 Posts
Top