Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Maybe someone has had this odd problem with high beams. The low beams work fine and the sentinel seems to be fine as well, but the high beams will work for a few flips on and off and then there is nothing for a few minutes and they will work again for a few clicks. Or once the high beams are on for more than 1 minute, I can't switch to low beams without manually turning the main light switch quickly off and on to low beam. A few hints are the main light switch seems a bit warm to hot after being on for 10 minutes or so and during the daylight, I can light the high beams by holding back the signal lever without having any lights turned on, however this is hit and miss as well. Any thoughts would be greatly appreciated.
 

·
Registered
Joined
·
7,658 Posts
You've probaby got a short somewhere........ Id suggest getting a new switch, and going from there......

More specifically, I think that somewhere, some wires are frayed and are rubbing together........ I could be wrong though.......
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
elwesso said:
You've probaby got a short somewhere........ Id suggest getting a new switch, and going from there......

More specifically, I think that somewhere, some wires are frayed and are rubbing together........ I could be wrong though.......
The previous owner let this car sit quite a while which didn't help the switches and relays I'm sure. I'll replace the main switch as you suggested and go from there. Is it normal to activate the high beams during daylight without having the main light switch on?
 

·
Registered
Joined
·
7,658 Posts
Yeah....... You should be able to flash the high beams any time you want..........
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
2 Participants
elwesso
Top