Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Cadillac
Joined
·
1 Posts
Discussion Starter #1
Im new here. Im trying to get my girlfriends car up and running. Its a 1987 Sedan Deville with the 4100 HT V8 auto. Whats going on is the speedometer stopped working. This is the second time its happened. The first time her dad took it to a shop and they fixed it. But, he doesnt remember what they did, who he took it to or anything. I just installed a water pump on it and the speedometer was working before I replaced the pump.

Can someone provide me with some info on this thing? I a ex Saab/Toyota tech, so working on isnt a problem...but, not knowing anything about this thing is.
 

·
Registered
'87 SDV
Joined
·
1,296 Posts
Is this a swing needle or digital speedo?

The system works pretty much the same either way, but the diagnosis tree is different. Briefly, there is a speed sensor on the trans which feeds a pulse signal to both the ECM and a buffer amplifier under the dash. The buffer amplifier then converts and feeds that signal to a quartz mechanism which operates either the needle or the digital display.

The water pump job probably had nothing to do with the inop speedo, unless you somehow disconnected the speed sensor. It's on top of the transmission housing at the governor cover, passenger side. The only device in that area with an electrical connector.

If that connection is okay, you'll need a voltmeter. I'd be happy to walk you through the diagnosis tree.
 

·
Registered
1987 Cadillac Coupe Deville
Joined
·
5 Posts
I have the factory original Cadillac Service manual. The flow chart isn't accurate
about the first thing to check It says to check the voltage at ickt 389 on the buffer. It should say check the 10 amp fuse labeled SOL in the hidden fuse box under the passenger side hush cover first. :annoyed: It doesn't take much to blow a 10 amp fuse when your replacing something on that side of the motor. Anyone can forget to take loose the negative battery cable from time to time.......
 

·
Registered
1987 Cadillac coupe Deville
Joined
·
1 Posts
Hey guys I have a 87 coupe Deville I tried installing a aftermarket CD player and I believe I didn't ground the black wire correctly. Everything worked perfectly fine for about an hour then the digital dash went out and so did the climate control and gas centre also blank please help thanks in advance God bless
 
1 - 4 of 4 Posts
Top