Cadillac Owners Forum banner

1 - 4 of 4 Posts

·
Registered
1996 Deville
Joined
·
67 Posts
Discussion Starter #1
1983 Coupe de Ville, HT4100.

It idles at what sounds like 1500-2000RPM. In hot weather, I can smell gasoline both at idle and while driving. No gas on ground. I can't see any kind of gas leak anywhere under the hood, with the engine running or off.

I have no idea if the gas smell and the high idle could be related, but they both happened after taking the car out of winter storage.

I tried doing the idle control motor relearn procedure. I wonder if I did it wrong.
--Engine warm and running
--Hold throttle at very high idle, push the idle control motor all the way in
--Quickly disconnect idle control motor connector
--Release throttle, let engine idle at low speed. Make sure there's a small amount of space between the motor control piston and the throttle.
--With engine running, plug the motor back in.

When I do that, the motor idles normally for about 30 seconds. Then the motor raises it to a high idle again.
 

·
Registered
1995 FWB 128,*** miles
Joined
·
2,257 Posts
Unfortunately, I do not remember much about ISC motor which I had to fix several times many years ago. Do a search, there should be a lot of info on the subject.
 

·
Registered
95 FWB 81SDV 96 FWB 94 Fleetwood
Joined
·
1,545 Posts
I have seen the switch in the idle motor control go bad. Its starts to work backwards. The first thing I would do is change the idle motor and see what happens. It could give you a check engine light.
 

·
Registered
Cadillac
Joined
·
870 Posts
Is the tank full? Recently filled? Rust on the top of the tank can create pinhole vapor leaks. Ask me how I know :oops:
 
1 - 4 of 4 Posts
Top