Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
1981 Eldorado, 1987 Fleetwood, 2002 Escalade
Joined
·
2 Posts
Discussion Starter #1
Hi,


I have a 1981 Eldorado. The power cut out and I can't figure it out. Just so you know, Alt, Batt, cables, fuse links, fuses, and connections are fine.
It does have Sentinal, and Electronic dash cluster.

Any thoughts?

Thanks,
Chuck
 

Attachments

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
Now that's an interesting roof treatment.

Just to clarify, there is NO electrical power? Not even "dumb" (non computerized) stuff? No horn, interior lights...?
 

·
Registered
1979 ELDORADO, also had a 1969 Eldorado
Joined
·
62 Posts
Hi, one of the worst places to park your car is on grass. (MOISTURE). I would remove the distributor cap, wipe it clean & spray some WD 40 or equivalent & give it a go.

Chris.....From OZ.
 

·
Registered
2001 Seville STS, 1990 Seville (RIP), 1972 Sedan Deville
Joined
·
26,323 Posts
He's yet to confirm weather It had no electrical power or if it "cut out", as in stalled and won't start. Parking on grass, in no way, shape, or form, will cause moisture buildup inside the distributor.
 

·
Registered
1981 Eldorado, 1987 Fleetwood, 2002 Escalade
Joined
·
2 Posts
Discussion Starter #5
Yes, no power anywhere. I am beginning to think it is the junction box on the firewall...

----------

Also, these pics are from where I purchased the car. I have owned it now for 6 months, and driven it almost daily.
 
1 - 5 of 5 Posts
Top