Cadillac Owners Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello everyone I'm new here and want to thank you in advance. I purchased this car about 20 years ago and been sitting in mothballs sense. With this epidemic my son has been home from college and has been on my tail to get it up and running - he loves this big tank. We have been working on the engine getting it running and she purrs. Now for the electrical which I'm not good at in the least. I have been chasing my tail around trying to figure out why I don't have power to some of the fuses in the fuse box. I thought one side of the panel is suppose to have power all the time on each fuse but not the case unless I'm missing some fuse able link some were. The inside lights, hazard lights, horn, no parking lights, no back up. I have taken a jumper wire and attached it to a strip of orange wire like a junction box behind the head light switch and some of the stuff works. Still no back up lights - if I put parking lights on I have both front and rear but one light on left rear doesn't light and no plate light. I have checked bulbs they're good and to see if got power but do not. Could it be a bad head light switch ?
 

·
Registered
96 FWB
Joined
·
596 Posts
.......We have been working on the engine getting it running and she purrs. Now for the electrical which I'm not good at in the least. ........
About the easiest - quickest - cheapest - most personally rewarding and best 'impressing offspring, SO and friends' things you can do is get a Factory Service Manual for your car. You'll soon:
- read and learn all about any of what sound like single and combined electrical issues you're having. Wiring diagrams and component/system descriptions will have you mopping each and all the problem spots up as you build experience that you admit you're no good at. You'll also be saving big bucks, aggravation and most importantly time, dealing with future issues as they surface v. going to a shop - which you'll find is always the case with a 1/2 century old car left to itself 20 years.

Just with what you've posted I'd:
- buy every single bulb listed for your car in the booklet at the car parts store
-get a big tube of dielectric grease when replacing every bulb in the car.
-buy an ebay or online .pdf copy of the FSM
-even before it arrives, check, clean and re-anchor every ground you can find under the hood, in the trunk and underneath the car.
-for a car left anywhere 20 years without one of those airtight bubbles you've got between 1 and 50 wires eaten by mice, and likely at least one electrical component with an ant nest.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
well your probably correct I have 2 manuals and I have replaced the bulb and put in dielectric. In the wire diagrams I only see 1 fuse able link in side the car which I find odd . I'm going to have to find all the grounds and clean them. I just can't figure why there is power to most of the fuses and not others . At first I thought the back of the fuse panel was rusted because the 4 bottom fuses are not working no power but they weren't. wire chasing is in my future .....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Well FTSS , I have been working on the wiring issue for the last couple of hour's and traced it back to the connection coming off the starter the connection was dirty cleaned them up and every thing is working. I have the back up light's ,plate light and left bottom parking light to take care of. I think the connection to the back up switch is dirty so I will tackle that tomorrow, I will also have to trace the plate light. My new water pump just got delivered so I will also be replacing that as well... Thanks for the input ftss....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
When I purchased this car years ago I had no idea how the previous owner jury rigged this car. Well I have found out why I have no back up light's ,the previous owner jumped the neutral safety switch as it was broken. I also found out why no plate light because there was no bulb. I am hoping once my new safety switch is put in that the rear lower parking light on the drivers will work but I'm thinking I have to take it out and check the wire's we will see.
 
1 - 5 of 5 Posts
Top