Cadillac Owners Forum banner
1 - 8 of 8 Posts

·
Registered
1971 Eldorado
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone, I'm new to the forums. I have a 71 Eldorado that I'm in the middle of restoring, I'll attach photos to this post. My problem is that the horn, wind shield washer, and rear lights are not working. I changed the fuses and I'm guessing maybe the wires need to be replaced after almost 40 years of New York winter and salt eating away at them. Does anyone have a clue to what the problem might be? When it comes to the horn, the little box near the fuses makes a noise but it doesn't make the horn sound. Any help would be appreciated!
 

Attachments

·
Registered
2006 XJ, 2000 Eldorado ESC--total loss :(
Joined
·
1,180 Posts
Wow, now that's an Eldorado! :)

None of those issues should share a common fuse, so I wouldn't spend any more time there. The best tool to get for this troubleshooting is a test light. I doubt that the wiring itself has failed, but very common to have corrosion in the connectors that is bad enough to cause total failure of systems.

If the horn relay clicks but the horns don't sound, pull the wire off one of the horns and put the test light at the connector (with a helper pressing the button) see if that is getting voltage. If it does, then I'm guessing you'll find lots of corrosion on the ground bolt and + connector for the horns (not likely that all 3 horns have failed).

Similar for the washer, see if you're getting 12v at the pump connector. If that pump setup is like the later '70s models, could be a mechanical fault such as the plastic drive ratchet, or the orings in the pump.

None of the rear lights work--tail or brake? They would be 2 separate circuits, so again my money is on cruddy connectors. Pull one of the bulbs out and probe the connectors in there.

Hope this helps get you started,
-Michael
 

·
Registered
1971 Eldorado
Joined
·
3 Posts
Discussion Starter · #3 ·
Michael thank you so much for your help. I got the horn working today and the lights fixed. The wind shield washer still doesn't come out though, on the odometer it says there is no wind shield washer even though it is full. Once again Michael thanks for the help!

John
 

·
Registered
77 CDV, 06 DTS III, 69 FWB
Joined
·
10,022 Posts
Beautiful car! 1971-1972 Eldo convertibles are one of my favorite Cadillacs!
 

·
Registered
2006 XJ, 2000 Eldorado ESC--total loss :(
Joined
·
1,180 Posts
Michael thank you so much for your help. I got the horn working today and the lights fixed. The wind shield washer still doesn't come out though, on the odometer it says there is no wind shield washer even though it is full. Once again Michael thanks for the help!

John
No problem, glad to hear it's working better!

Is your washer pump the type that is mounted on the back of the wiper motor, with 2 different connectors (one for the wiper motor, the other 2 wire for the pump)? I have to take a look later and see if I can find more info...

The low washer fluid light is a separate issue. Just a float with a switch to turn that bulb on and off, usually just a bad switch.

BTW, last year I almost bought a '72 Eldo convertible in lime green :) Would have got it, but the top was left open for 10 years and the interior was shot, no electrical worked :-(
 

·
Registered
1971 Eldorado
Joined
·
3 Posts
Discussion Starter · #6 ·
Once again thanks for the help! I have another issue though. My white Caddy (the one in the picture) does not have chrome on the doors. I have a black 71 Eldorado parts car with the chrome (on the doors). My question is, any idea on on how to take the chrome off? There is not much space to work on taking it off and I also don't want to do anything that might bend/ mess up the chrome. If you have any advice, let me know mate!

Cheers :)
 

·
Registered
2006 XJ, 2000 Eldorado ESC--total loss :(
Joined
·
1,180 Posts
If you have the donor car apart, does the trim have screws through the door panel? I don't know specifically your year, but that era car had trip attached to clips, which were either screwed or riveted to the body. I'd try to drill out the rivets to get the trim off, and then see how the clips are holding the trim. Usually you used a tool to pop the clip out of the trim piece, but you have to know how it worked 1st (I know that doesn't really answer your question)

Did you get the washer pump working again?
 

·
Registered
1971 Eldorado Convertible
Joined
·
1 Posts
I just found this forum and have joined. I need help on this subject as well. I, too, have a 71 Eldo Convertible and having trouble with the washer pump. It's getting power, but the replacement pump I bought isn't working. Although it says it belongs on this particular car, it does look a bit different from the one I took off.

Also, my sound system is completely dead. I have no idea if it's the radio/8 track itself, or just the speakers. Any input would be appreciated!

I have pics of the car in my profile, if anyone wants to see :)

paul
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top